Announcement

Collapse
No announcement yet.

Minor Help with Subscripton - Custom User Titles

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Minor Help with Subscripton - Custom User Titles

    I am still trying to learn how to use vBulletin and what I have done is set up a subscription on my forum for a "Collector's Club" with forums that are only accessable for members. I also created a new users group called "ZZZ Collectors Club" and I created new forums and I was able to set permissions so only Group members and Mods - Admins can see them...

    I also want to be able to give a custom "User Title" but I can't figure out how I do this...

    Thanks for any help!

    Oh Yea... I am using vB-3.0.7
    Last edited by Quarterbore; Fri 1 Apr '05, 8:38am.
    vBClassified.com
    TimeshareForums.com

  • #2
    Custom titles are a group permission:

    Admin CP -> Usergroups -> Usergroup Manager -> Edit Usergroup -> Can Use Custom Title

    Comment


    • #3
      I verified that this was the way I had things set... and I did... still doesn't work?

      Also, that is where I had set what I wanted displayed and the info is still there
      vBClassified.com
      TimeshareForums.com

      Comment


      • #4
        Make sure that 'Allow Users to have Member Groups ' is set to Yes for the main group.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Yes... Under Admin > Usergroups > Usergroup Manager > Registered User >

          'Allow Users to have Member Groups ' is set to Yes

          Also, I know that the user group is working as I have two test member accounts.. I subscribed one through the Admin Panel while the other was not joined... The hiddeg forum shows up fine or Doesn't show up like it should...

          Only the crazy inabuility to change the user title seems to be a problem for me
          vBClassified.com
          TimeshareForums.com

          Comment


          • #6
            Try one more thing - update the User Titles counter:

            Admin CP -> Import & Maintenance -> Update Counters -> Update User Titles
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Nope... I had tried that before too... I did it again with no luck...

              Both my test account and my one member that has subscribed come up as "Junior Member" ... My member has one posts so far and my test account has two... That shouldn't matter, right?

              -----------------------------------------------------------------
              EDIT BEFORE I EVEN POST...

              OK, what the #$#@?

              I went into my....

              Admin CP > Users > Search for Users > "My Test User Acct"

              In that area I see my Test Account is still under "Registered Users" and not my "Club Group". When I switched the user from "Registered" to "Club" the custom title worked!

              So, do I need to manually go in and promote every person to this group when they subscribe? It is strange as in the subscription area I had done the following:
              1. Filled out the box on left for title, decription, made it active, period and cost.

              2. In box on right changed the User group to "Registered" with an extra Check next to my "Club" group.

              3. I changed the access to my hidden "Club Only" forums to "YES" while the rest were DEFAULT
              Now, I had also tried to change the the box #2 above to "Club" in the pull-down but that didn't seem to help either....

              If I manually set the group from "Registered" to "Club" in (Admin CP > Users > Search for Users > "My Test User Acct") then I assume the subscription will not end when the time is up... I am pretty sure that this is not the correct fix for my problems (Like there is any fix for MY problems but you know what I mean )

              EDIT 2:

              I just noticed another quark in what I have...

              When I am in subscriptions I clearly see two subscribers to the club...
              When I am in Usersgroups (Custom Usergroups ) Only the one I manually upgraded is in the club shows up...

              EDIT 3 - A few more notes:

              I also find it interesting that in the member that joined that they have listed below their account:

              MEMBER NAME is a member of the following groups:M9 Bayonet Collectors Club:
              M9 Bayonet Collectors Club


              For now... I went into the Admin area for Users and edited the profile by hand so it looks like this:

              <snip> ... that didn't work... I'll post a pic in a sec! </snip>

              Now, out of curiousity... I went ahead and went into my Admin Area and DISABLED the subscription for my Test Accout that I had manually set permissions to access this area and the test account lost the custom aviator, custom tag, and access to the hidden forum. Still doesn't seem I should need to manually set the displat and additional groups like above but... what do I know as a user of this system for about 5-days!?!
              Last edited by Quarterbore; Fri 1 Apr '05, 7:17pm.
              vBClassified.com
              TimeshareForums.com

              Comment


              • #8
                OK, I feal stupid now as I don't know what I changed but it is working now...

                Following is an image of the member that I manually set so that the group worked....



                I just went in and subscribed my second test account (After screwing with all kinds of settings to get the above acount and my 1st test account to work) in order to show what the initial usergroup came up as... WELL, IT IS WHAT IT WAS SUPPOSED TO BE ALL ALONG!



                So, it seems my problems are fixed not that I really have any clue what I did to fix them...
                vBClassified.com
                TimeshareForums.com

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X