Announcement

Collapse
No announcement yet.

Again an e-mail problem.... :-(

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Again an e-mail problem.... :-(

    Hi all;

    I reinstalled my vB; now activation mails don't go to the members (avaiting confirmation).. I did some settings like below; but still the same problem there is..

    - Admin CP -> vBulletin Options -> Server Settings and Optimization Options - > Enable "-f" Parameter -> Yes

    - in config.php I added this: <?php
    ini_set("sendmail_from", " [email protected]");

    - Admin CP -> Imports & Maintenance -> Diagnostics -> Email >>

    SMTP: localhost
    sendmail_from: [email protected]
    sendmail_path: /usr/sbin/sendmail -t -i

    What should I do different..? Thanx....

  • #2
    Any idea...¿ :-(

    Comment


    • #3
      Do any vB email functions work? Did you get the test email?

      You will need to view the mail logs on the server to see what happened to those emails that don't work. Once vB sends it to PHP it's in the hands of the server. If you are on a shared server you may need to ask your host to look through the logs for you.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        OK I understood.. I'll look these.. Thanx very mch...

        Comment


        • #5
          I talked with my hosting contact. He will look this.

          Also; I can send e-mails over Outlook Ex. or Webmail (in control panel) by using [email protected].. but only it doesn't work over the vB.....?? This is the error below.. (I edited it little mydomain etc..)

          To : Mail Delivery System

          From : [email protected]

          To : Mail delivery failed: returning message to sender


          A message that you sent could not be delivered to one or more of its
          recipients. This is a permanent error. The following address(es) failed:

          [email protected]
          unrouteable mail domain "hotmail.com"

          ------ This is a copy of the message, including all the headers. ------

          Return-path: <contact@mydomain.com>
          Received: from nobody by server.indexservers.net with local (Exim 4.50)
          id 1DHTrd-0007mU-5u
          for [email protected]; Sat, 02 Apr 2005 00:39:37 +0300
          To: [email protected]
          Subject: xxx Forum! üyeliğinizin tamamlanması için aktivasyonu onaylamalısınız.
          From: "xxx Forum Forums" <contact@mydomain.com>
          Message-ID: <[email protected]>
          X-Priority: 3
          X-Mailer: vBulletin Mail via PHP
          MIME-Version: 1.0
          Content-Type: text/plain; charset="ISO-8859-9"
          Content-Transfer-Encoding: 8bit
          Date: Sat, 02 Apr 2005 00:39:37 +0300

          Last edited by organik81; Fri 1 Apr '05, 1:58pm.

          Comment


          • #6
            unrouteable mail domain "hotmail.com"

            This is a server configuration problem. Read this:
            http://www.vbulletin.com/forum/showp...6&postcount=20
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              If you are using WHM/Cpanel for yours, then under WHM you will find under "tweek settings", this option
              Prevent the user 'nobody' from sending out mail to remote addresses (php and cgi scripts generally run as nobody if you are not using phpsuexec and suexec respectively.)
              Uncheck that option and that will allow the mails to go through.
              I unchecked this too... There is no any change.. Still e-mails don't go.. My webhost told me that the "tweek settings" are default and correct... Can be any different way to fix this mistake...?

              Comment


              • #8
                You'll need to ask your host to fix this. Obviously their server cannot find a route to hotmail.com:

                unrouteable mail domain "hotmail.com"

                This is not a vB controllable issue.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Thanx very much.. We corrected the problem form WHM options..

                  Comment


                  • #10
                    I have a problem which may or may not be related. I enabled welcome email, changed the text, registered a username as a test, and no email arrived. Then I sent the pw via email, and that has not yet arrived either. No spam filtering exists on the account.

                    Comment


                    • #11
                      Never mind, enabling -f parameter may, or may not, have cured this. Too early to be sure, but early results look good.

                      Comment

                      Loading...
                      Working...
                      X