Announcement

Collapse
No announcement yet.

Major Install Frustrations

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Major Install Frustrations

    I purchased Vbulletin last night and failed many times to install. I need some help.

    I keep getting stopped on step 2 with this error:

    "The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file"

    I have checked and re-check and tried many different settings to get that config file to work. Even the same settings that previously worked fine with my phpbb forum.

    Here is some of my info:
    -yahoo small business web hosting
    -phpmyadmin 2.5.0 for working with mysql 3.23.49

    If anyone could help that would be great, I spent nearly 6 hours trying to solve this last night.

    Thanks

  • #2
    I went into phpmyadmin...

    created new db with name "vbulletin"

    ran this script with my info inserted

    GRANT ALL ON example_database.*
    TO example_user@localhost IDENTIFIED BY 'p4ssw0rd';

    It was successful....

    In my config file I entered the exact same info and it still doesnt work

    Comment


    • #3
      ok i ran your test program and got the following:



      How can I change the permissions?

      Comment


      • #4
        And you're sure the config settings are correct?

        $servername = 'example_server_address';
        // ****** DATABASE USERNAME & PASSWORD ******
        // This is the username and password you use to access MySQL.
        // These must be obtained through your webhost.
        $dbusername = 'example_user';
        $dbpassword = 'p$ssw0rd';
        // ****** DATABASE NAME ******
        // This is the name of the database where your vBulletin will be located.
        // This must be created by your webhost.
        $dbname = 'example_database';

        Is it possible your settings are off? Your config.php file was renamed from config.php.new to config.php right?

        Comment


        • #5
          yea, i have re-checked the settings many times

          Comment


          • #6
            here is a screen shot that confirms my privleges to the database im trying to use

            http://extremev6racing.com//TempImaging/phptest2.jpg

            Comment


            • #7
              Have you check the user has the required permissions to the MySQL database? Your host should be able to confirm this for you if you are unsure.

              Comment


              • #8
                Originally posted by Boxy
                Have you check the user has the required permissions to the MySQL database? Your host should be able to confirm this for you if you are unsure.
                yea, look at the post just above yours... it confirms that i have privleges to that db
                Last edited by danhaga; Tue 29 Mar '05, 5:51am.

                Comment


                • #9
                  ok I changed my server name from "localhost" to "mysql" and it passed. Now the only fail I have is:

                  "magic_quotes_gpc must be off for vBulletin to work correctly, ask your host to change this in php.ini"

                  Where do I find the php.ini file to change it?
                  Last edited by danhaga; Tue 29 Mar '05, 6:16am.

                  Comment


                  • #10
                    php.ini is normally located in usr/lib/php/

                    You will need to restart the webserver (Apache) if you make any changes.

                    Comment


                    • #11
                      Originally posted by Boxy
                      php.ini is normally located in usr/lib/php/

                      You will need to restart the webserver (Apache) if you make any changes.
                      ok, i dont have that directory and I dunno what apache is... I have acces to everything on my server and database.... is this something i need to contact yahoo for?

                      Comment


                      • #12
                        ok... vbulletin is installed and looks to be working...

                        i did not yet fix the error:

                        "magic_quotes_gpc must be off for vBulletin to work correctly, ask your host to change this in php.ini"

                        what does this effect with vbulletin if i leave it?

                        Comment


                        • #13
                          No it will be fine

                          Comment

                          Loading...
                          Working...
                          X