Announcement

Collapse
No announcement yet.

Attachments problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachments problem

    I have a problem when trying to attach an image.
    I just recently purchased vbulletin so I'm running the latest version. Permissions look to be set correctly and the images are stored in the database (for the moment)

    In the manage attachments window I get the following message
    "File Too Large. Exceeds PHP's limit of 2,097,152.00 GB. "

    The image is only 65K ???
    any ideas what's going on ?

  • #2
    First, check your attachment size setting in the Admin CP and make sure it's large enough.

    Then run the Upload Diagnostics and report back the results:

    Admin CP -> Import & Maintenance -> Diagnostics -> Upload

    Also, in the Admin CP, open the Server Settings and Optimization Options section and turn on the Public phpinfo() Display Enabled setting. Then provide the URL to your forums. This may help us troubleshoot this problem.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Hi Steve

      The attachment extensions & sizes are as follows:
      Extension: jpg
      Maximum Filesize: 100000
      Max Width: None
      Max Height: None
      Enabled: Yes
      the file I was uploading was a .jpg image 75Kb in size

      I was able to upload a .gif file 1Kb in size good start...

      The result of the diagnostics is as follows:
      file_uploads: On
      open_basedir: None
      safe_mode: Off
      upload_tmp_dir: None
      upload_max_filesize: 505050505050505050505050505050505050505050505050505050505050505050505050505050505050505050 5050505050M

      No errors occurred while opening the uploaded file for reading.

      BTW I swithched the attachment storage type to 'filesystem' and I still get the same error. The directory that I created for storing attachments has its permissions set to 777

      I've also asked my host provider about this problem - they say the php max file upload size is set to 2Mb.

      Any clues what to try next ???

      Comment


      • #4
        upload_max_filesize: 50505050505050505050505050505050505050505050505050 50505050505050505050505050505050505050505050505050 M

        That is the most likely problem. This is an unreasonably large number and the server is probably having problems with it.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          I guess this is a setting in PHP ? Do I have to get my host provider to fix it ?

          Comment


          • #6
            Originally posted by the123d
            I guess this is a setting in PHP ? Do I have to get my host provider to fix it ?
            No, you lower the number. :P Or just put a "0", to indicate no limit.

            Comment


            • #7
              Thanks for your feedback TCM - but it seems to me that this is a php setting. When I look at the phpinfo page it clearly lists
              upload_max_filesize : 505050505050505050505050505050505050505050505050505050505050505050505050505050505050505050 5050505050M

              Since I don't have access to php - I've asked my host provider to look into it...

              hope that fixes the problem - will post the result later ...
              Last edited by the123d; Fri 25 Mar '05, 12:27am.

              Comment


              • #8
                Yes, your host will need to fix this in the server's php.ini file.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment

                Related Topics

                Collapse

                Working...
                X