Announcement

Collapse
No announcement yet.

putty.exe

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • putty.exe

    When backing up with Putty, how do you know when it's finished, it doesn't tell you anything.

    I look at the sql file in the root folder, and when the size stops growing, I know it's done, but shouldn't putty tell you something?

    Thanks

  • #2
    You should be returned to the command prompt when it's done.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      For me, it goes to the command prompt after pushing enter, when you start the job. Is that normal?

      Comment


      • #4
        it should look like

        [[email protected] root]./db_backup.sh

        then hang and once its done you'll get a new line with
        [[email protected] root]
        Scott MacVicar

        My Blog | Twitter

        Comment


        • #5
          It hasn't been doing that for me. The window stays the same. I just give it enough time and then close it.

          I am following everything, so I don't know why it would be different.

          I connect, and enter password.

          Then I enter:
          mysqldump --opt -Q -h serverurl -u username -p dbname > domain.com/backup/name.sql

          Then, it says "password" and I enter it. Then, I get the green cusror, and the file is made, but nothing else happens in putty.

          I am using these instructions, and here, it doesn't say anything about the cusror.
          http://www.vbulletin.com/docs/html/m...nce_ssh_backup
          Last edited by indie; Mon 21 Mar '05, 6:32pm.

          Comment


          • #6
            Maybe the prompt is different with each host, and I'm currently on a shared plan, so maybe it's different?

            I dont see the folders and files like I do with ftp. All I see is the prompt, and I enter the code, and it creates the file.

            Maybe that's how it's done using my host?

            Thanks

            Comment


            • #7
              The only way you should be immediately returned to an O/S prompt is if you add the "&" at the end of the command.

              Comment


              • #8
                Anyway to tell if it's complete?

                The first line starts with:-- MySQL dump
                And the last line is username tables, and ends with: ;UNLOCK TABLES; /*!40000 ALTER TABLE `word` ENABLE KEYS */;

                Also, what is the -Q for in the command. I was told I don't need it, and have seen it used, and not used in some posts.

                Thanks!
                Last edited by indie; Mon 21 Mar '05, 9:49pm.

                Comment


                • #9
                  OK, I watched the putty window, and yes, it returns to the prompt when it completes.

                  The prompt is a dollar sign.
                  $
                  And I enter the command after the dollar sign, and then it asks for the password, and when it completes (a few seconds later) the dollar sign returns, so I assume this is correct.

                  Now, can someone comment on my previous post? Thanks a lot!

                  Comment


                  • #10
                    Originally posted by indie
                    OK, I watched the putty window, and yes, it returns to the prompt when it completes.

                    The prompt is a dollar sign.
                    $
                    And I enter the command after the dollar sign, and then it asks for the password, and when it completes (a few seconds later) the dollar sign returns, so I assume this is correct.

                    Now, can someone comment on my previous post? Thanks a lot!
                    from man mysqldump

                    -Q|--quote-names
                    Quote table and column names with รข
                    and yes that is a correct prompt if you are logged in as Root. # prompt is for users, $ is for root. Unless of course i have that backwards.

                    Comment


                    • #11
                      OK thanks.

                      So, do we need the -Q in the command? I've seen instructions on this forum with it (in the vb manual) and other support techs have left it out in their posts, so not sure.

                      mysqldump --opt -Q -h serverurl -u username -p dbname > domain.com/backup/name.sql

                      Thanks!

                      Comment


                      • #12
                        Use the example in the docs.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          http://www.vbulletin.com/docs/html/m...nce_ssh_backup
                          This has -Q

                          http://www.vbulletin.com/forum/showp...09&postcount=7
                          This one does not have -Q

                          Just wondering whic is correct? Thanks again for your help.

                          Comment


                          • #14
                            Again, use the example in the docs. However both are correct and will work.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X