Announcement

Collapse
No announcement yet.

Did I do something wrong?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    I may have misunderstood the problem. For secondary groups, you can seet this to 'Yes':

    Can override primary group title/markup

    Then in their User CP/Group Memebrships options, they should see the option to 'Identify me as a member of this group'.

    Does that resolve this?

    Leave a comment:


  • Zenith
    replied
    Here's a query for those who want to force all members of a secondary user group to use that group's html markup. Doesn't stop users subsequently changing it in their usercp though.

    UPDATE user SET displaygroupid=X WHERE FIND_IN_SET(X,membergroupids)

    Where X = id of the secondary user group

    If there are then users who you want to keep their primary groups html markup, you can set them back again with

    UPDATE user SET displaygroupid=0 WHERE usergroupid=X

    Where X is primary usergroup id (e.g. 6 for admins)

    Back up user table first. Worked fine here but no responsibility taken.

    Leave a comment:


  • Zenith
    replied
    Your users have to go into the usercp and select which group they want to be displayed as. It defaults to their primary group, so secondary group html markup won't display no matter what you do unless your user has the secondary group selected in their usercp/group memberships.

    This is quite painful and puts a real obstacle in the path of automated paid subscriptions.

    Leave a comment:


  • Steve Machol
    replied
    Try the img tag on a regular group without all the secondary issues. If it doesn't work, then this means you cannot use this tag in the HTML Markup.

    Leave a comment:


  • drorgh
    replied
    precisely what happen to me ..
    you can see that in my forum, twist..
    www.twist.co.il

    Leave a comment:


  • Andy Huang
    replied
    Nope, updating User Titles counter doesn't work...

    How would you suggest come about doing it? I am kind of fresh out of ideas right now...

    Leave a comment:


  • Steve Machol
    replied
    I don't know if that will work or not, but you might want to update the User Titles counter.

    Leave a comment:


  • Andy Huang
    started a topic Did I do something wrong?

    Did I do something wrong?

    Ok, here's what I want to do and what I've done and what's happening...

    What I want:
    I want to add a little icon infront of usernames of a certain group so their name stands out in the forum without being intrusive (IE: bold/italic/both).

    What I did:
    I created a new usergroup called DevIcon with no particular permissions. I set the usergroup's Username HTML Markup with <img src='path/to/devicon.gif'>, and set Can override primary group title/markup to yes. I then added the people I want to have icons for into that user group as their secondary user group.

    What's happening:
    I don't see the icon on the forum....

    Am I doing something wrong? Why is it not overriding?

    Note: the <img> tag is NOT in the page's HTML...
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X