Announcement

Collapse
No announcement yet.

Logout never shows java prompt...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Logout never shows java prompt...

    Ok, I have an issue with the "button bar" part of the "navbar" template. But first...

    debian stable
    php 4.3.10 (gd and mysql)
    mysql 4.1.10
    vb 3.07 (clean install)

    Now...I created a new skin, and moved the "buttonbar" part of the "navbar" template into the "header" template, along with the associated javascript. It works fine in NS and other moz compat things, however, the javascript prompt never shows in IE (fully patched v6) even though the filter takes affect. If you alt-tab to another window and then come back, the dialog shows, but not until then. I tripple checked my cut and paste with the default skin's templates, and it's all intact, just moved. Any idea why this might happen, or how to fix it? I can't go live until this is resolved.

    [edit] I just noticed, the "Log Out [username]" link near the bottom of the page has the same oddity and I didn't change that at all.
    Last edited by RagingPenguin; Sat 12 Mar '05, 6:06am.
    House of Night Forums - An online House of Night roleplaying community,

  • #2
    Anybody? Is it just a problem with IE and java or what?
    House of Night Forums - An online House of Night roleplaying community,

    Comment


    • #3
      Steve? Zach? This is just got my "oh, this is more serious than I thought" vote. Upon further testing, I found that this strange behaviour is not limited to my site. I've tested it on other forums as well, http://forums.deviatedhq.com/forums.php for instance, none of which are mine, or appear to have much changed other than css. It also seems to occurr only on the index. If you go into a forum or feature, like the calendar, clicking "Logout" works as expected. I do not know, however, if this oddity is limited to the IE6/WinME combination or not, but that's all I have to test on. Again, NS, Moz, Firefox are all ok. Considering that most lay people use IE, since it comes with windows, this needs a serious investigation. As it is now, I've put my site development on hold. If you'd like to look for your self...

      http://wizardingrealm.com/new
      Username : Voldemort
      Password : goddard (will change after issue is resolved)
      Last edited by RagingPenguin; Sat 12 Mar '05, 6:17am.
      House of Night Forums - An online House of Night roleplaying community,

      Comment


      • #4
        I will take a better look when I get home, At college, can't do too much here

        Comment


        • #5
          Much obligded. I await your discoveries.
          House of Night Forums - An online House of Night roleplaying community,

          Comment


          • #6
            Here's a follow up for you Zach, for when you get a chance to look at this. It seems to have narrowed itself to an IE6 flaw *no surprise there* when used on WinME (not sure about other operating systems). We still need a fix though because a lot of people use this combo. Here's what I found out after further testing...

            1) My assumption that the box never shows is false. It is created, but never displayed. If you click "logout" then "enter", you'll be logged out. If you click "logout", "tab", then "enter", it cancels. You can force the box to display by causing a screen redraw by pressing "alt" as if you were about to access the boxes system menu.

            2) After commenting out the lines in "function log_out" that affect the filter, the box shows fine. This may indicate a problem with a fully patched IE6 on WinME in regards to the DHTML engine.

            I'm not sure where to go from here. While I can switch to Win2k personally, I like the DHTML filter for my IE users, who may be using WinME. What I need is a confirmation that this is indeed a problematic combo so I can report the error to M$. I'll be reinstating the filter affect so you can see this for yourself. If no solution is reached, I may just kill the filter.

            And Zach...thank you very much ahead of time for indulging this issue, even though it doesn't seem directly related to vb at this point.
            House of Night Forums - An online House of Night roleplaying community,

            Comment


            • #7
              Still need to make sure.

              I would guess that somthing is setting off something like NIS or something of the like on the person who is on WinME computer.

              I have only Windows XP/XP64/2003 and MacOSX to test on.

              Since XP/2003 use the same IE, I know that since its working on my pc, it works on my 2003 server.

              It should work on IE64 but since no one is using it, I'm not going to check at this time.

              I think it its releated to a third party program rather than IE itself, unless you can get a fresh instaltion of ME to do this.

              (I might be able to find my old ME disk, but I am doubtful at best)

              Comment


              • #8
                Ok, here's what I am going to do. I have to backup a ton of stuff, but I'll do it for the good of the community, then re-install WinME/IE5, test, IE6, test, patch, test, install NS, test again (to make sure NS's js isn't goobering up IE's). I'll report at what point it fails.

                I hope this helps more people than just myself...be back in about an hour and a half.
                House of Night Forums - An online House of Night roleplaying community,

                Comment


                • #9
                  Try this. Create a new style and choose no parent style. This will force it to use the default templates. Then change to this style and view your forums with it. Do you have the same problem?
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    I Already did that as part of my test and that worked fine. Here's what I just did beyond that.

                    Action: Formatted hard disk, performed a clean install of WinME (IE 5.5).
                    Result: Layout off and filter abscent (both expected). Confirm dialog displays.
                    Action: Installed IE6SP1 and rebooted. No patches yet.
                    Result: Layout correct and filter present. Confirm dialog does NOT display untill forced to via a new WM_PAINT message.
                    Comment: Decided to test default skin at this point.
                    Result: Filter present and dialog displays regardless of page (index, showthread, etc...)
                    Comment: Retested custom skin.
                    Result: Filter present but dialog absent (exists but invisible) for index.php. All other pages ok.
                    Conclusion: Despite XHTML and CSS validity, there is a problem with my index templates. Here's what is customized...
                    1) $spacer_open is now three opening layout divs (<div>'s for wrapper, left edge effect and righ edge effect).
                    2) $spacer_close is now three closing layout divs (</div>'s for above)
                    3) Used search and replace to remove all current instances of the above.
                    4) Added $spacer_open to $header and $spacer_close to $footer.
                    5) Moved "buttonbar" from $navbar to $header and changed textual links to rollover images. *
                    6) Added a few divs here and there to seperate display areas. *
                    * The button bar and the log_out script are inside a div at this point. I tried placing the default skin's log_out script in a div as a test, and it worked fine.
                    ** EX: <div class="mleft"><div class="mright"><div class="mcenter"></div></div></div> - Provides horizontal wooden bar. Several variations.
                    I have been over my changes carefully, backtracking and reverting, then reapplying each change. I simply cannot isolate the fault. Again, the w3.org says I have valid XHTML and CSS so I am stumped. Feel free to visit and look at the source html for the page and see if there's something *stoopid*, even if technically correct, that may cause the problem. I think it resides within my implementation of the buttonbar itself...
                    House of Night Forums - An online House of Night roleplaying community,

                    Comment


                    • #11
                      *NOTICE*

                      I figured it out!

                      When I noticed that this odd effect only occurred on the index, working only on the rare instance, I put my efforts into isolating the difference between the index, my other pages (forumdisplay for example) and the stock skins index. After much trial and error, I discovered that the animated statusicon forum_new.gif from my custom skin was the only viable difference. I took the stock skin and hardcoded the path to that icon in the FORUMHOME statusicon section and viola! Attempts to logout now also hung. That being the ONLY change to that skin. Interesting eh? Now, to find a way around it...is there a way that anybody knows of to programatically stop animated icons from looping?

                      Don't you wish more people would put this much effort into debugging their own stuff?

                      House of Night Forums - An online House of Night roleplaying community,

                      Comment

                      Loading...
                      Working...
                      X