Announcement

Collapse
No announcement yet.

SQL error on search of "first car"...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • pieman666
    replied
    /includes/searchwords.php has words that are not indexed I'm not sure if it prevents a search as well. So you may have to reindex/delete the terms from the search index.

    Leave a comment:


  • RobFerrari
    replied
    Originally posted by Steve Machol
    I would double whatever the setting is now.
    Thanks, that worked.

    Searching for "first car" vB took out "first" because it was a common word and just searching for "car" on an automotive site must have overloaded it. Where can you manage what words vB won't search on?

    Leave a comment:


  • Steve Machol
    replied
    I would double whatever the setting is now.

    Leave a comment:


  • RobFerrari
    replied
    Originally posted by Steve Machol
    That's the problem:

    mysql error: Got a packet bigger than 'max_allowed_packet'

    You or your host will need to increase the max_allowed_packet setting in my.cnf/my.ini.
    What would you recomend for this setting?

    Thank you,
    rob

    Leave a comment:


  • Steve Machol
    replied
    That's the problem:

    mysql error: Got a packet bigger than 'max_allowed_packet'

    You or your host will need to increase the max_allowed_packet setting in my.cnf/my.ini.

    Leave a comment:


  • RobFerrari
    replied
    Originally posted by Steve Machol
    What are the last 5 or so lines of this error?
    ...

    AND delpost.primaryid IS NULL
    AND post.visible = 1

    mysql error: Got a packet bigger than 'max_allowed_packet'

    mysql error number: 1153

    Date: Friday 04th of March 2005 01:49:59 PM
    Script: http://www.ferrari101.com/forum/search.php
    Referer: http://www.ferrari101.com/forum/
    Username: Rob Lay
    IP Address: 199.33.140.2

    Leave a comment:


  • Steve Machol
    replied
    What are the last 5 or so lines of this error?

    Leave a comment:


  • RobFerrari
    replied
    Originally posted by Steve Machol
    Try lowering this setting:

    Admin CP -> vBulletin Options -> Message Searching Options -> Maximum Search Results to Return
    It was at 250, I tried 200 and 100 with same error returned. I tried both the popup Search and Advanced Search.

    I've never seen this error before.

    Leave a comment:


  • Steve Machol
    replied
    Try lowering this setting:

    Admin CP -> vBulletin Options -> Message Searching Options -> Maximum Search Results to Return

    Leave a comment:


  • RobFerrari
    started a topic SQL error on search of "first car"...

    SQL error on search of "first car"...

    For some reason, if you search for "first car" the search times out and locks with the following error...

    Database error in vBulletin 3.0.7:

    Invalid SQL:
    SELECT post.postid, post.threadid
    FROM post AS post
    INNER JOIN thread AS thread ON(thread.threadid = post.threadid)
    LEFT JOIN deletionlog AS delpost ON(delpost.primaryid = post.postid AND delpost.type = 'post')
    WHERE post.postid IN(478,484,498,504,514,521,523,532,533,541,546,566...
    Those numbers go for what seems forever, I think every single post id. I have 3.0.7.

    Thank you,
    rob

Related Topics

Collapse

  • ali.almabhouh
    Search Error
    by ali.almabhouh
    Hello I have a weird issue with search engine
    When I search in English or Arabic I have no issues but when I try searching with Russian language I get this error

    Code:
    Your criteria is not
    ...
    Fri 14 Jun '19, 12:12am
Working...
X