Announcement

Collapse
No announcement yet.

Error.. Need Urgent Help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error.. Need Urgent Help

    Attempting to attach to database

    Connect failed: unexpected error from the database.

    Error number: 1044

    Error description: Access denied for user: '[email protected]' to database ' lgasomme_vbb'

    Please ensure that the database and server is correctly configured and try again.
    My SQL host isn't localhost, yet I changed it to the proper host in config.php, but it still shows up at @localhost! Is there another file or something?
    The Somme Valley - Leader, Web Master, Historian

  • #2
    This error means either:

    1. One or more of the following is wrong in your config.php file:

    $servername (except in rare case, this should almost always be left as 'localhost')
    $dbusername
    $dbpassword
    $dbname

    If you are unsure of what the appropriate values are then you will need to ask your web host.

    2. Or that this db user is not assigned to that database or does not have permission to access MySQL to create or access a database. You may need to first manually create the database and assign the db user to it. Since each web host is different, if you do not know how to do this then contact your web host for help.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol
      This error means either:

      1. One or more of the following is wrong in your config.php file:

      $servername (except in rare case, this should almost always be left as 'localhost')
      $dbusername
      $dbpassword
      $dbname

      If you are unsure of what the appropriate values are then you will need to ask your web host.

      2. Or that this db user is not assigned to that database or does not have permission to access MySQL to create or access a database. You may need to first manually create the database and assign the db user to it. Since each web host is different, if you do not know how to do this then contact your web host for help.
      I know all of that.. I changed it all, but the host still shows up @localhost, its reading localhost from somewhere. The Servername is mysql.edgenetwork.org, not localhost.. so I changed it... but it diodnt work, thats my problem.
      The Somme Valley - Leader, Web Master, Historian

      Comment


      • #4
        If you changed it in includes/config.php, then it would not show localhost. That is the only place this could come from.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          apparantly its just a mask, I talked to my admin, and he did somethin, fixed it for me.. Thanks for the help fellas, but its all solved now
          The Somme Valley - Leader, Web Master, Historian

          Comment


          • #6
            Hi Chief
            I have the same problem...can you ask your admin what he fixed and pass the info along? We're going absolutely nuts here trying to sort this error out
            Thanks

            Comment


            • #7
              Me too...this is getting crazy.

              Was there some kind of security (or otherwise) thing put into 3.0.6/7 that could be causing this?
              My Live vB5 Site - NZEating.com
              vBulletin Hosting | vBulletin Services - Need hosting for your vB? Need it installed? Something else? Let me take that hassle off your hands.

              Comment


              • #8
                No, this is not a vB caused problem. If you are talking about the error in post #1, the solution is in post #2.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Oh true, I'm sorry.

                  My problem is the 'I have received about 150 error messages today telling me mysql has failed and am experiencing random failures myself' one.
                  My Live vB5 Site - NZEating.com
                  vBulletin Hosting | vBulletin Services - Need hosting for your vB? Need it installed? Something else? Let me take that hassle off your hands.

                  Comment


                  • #10
                    That is not the same error that this thread is about.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X