Announcement

Collapse
No announcement yet.

Mass Email Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mass Email Problem

    I have a problem useing mass email to all users, when I send a email I am the only one to get the email user id 1 no other admins,mods, or any other user group get emails.

    Send email on registraton and all the other forum email options are working to the best of my knowlege.

    The board is running vb3 3.0.5 and was upgraded from vb2 2.3.5 before that emails were working fine. I can only think that it may be a user table problem in the database that was caused by the upgrade as I am sure the admin/email.php is sound.

    I have checked and read most of the threads relateing to admin email and general email problems before I posting this.

    To confirm this, these are the settings I have done.

    Server Settings and Optimization Options

    Number of Emails to Send Per Batch = 100
    Use Mailqueue System = yes
    Enable "-f" Parameter = yes

    Diagnostics
    Email

    Email: [email protected]

    Diagnostics works to send to admin userid 1 email account and 2 other normal user accounts.

    Is there anything at all that I am missing here? a fault finding checklist would be good.

    thx...
    Last edited by DR€@M W€@V€R; Fri 4 Feb '05, 12:28am.


  • #2
    Do your users have 'Allow Admin Emails' set to 'No'?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Default Registration Options
      Receive Admin Emails = yes

      Were do I find 'Allow Admin Emails' is that in the usergroup manager?

      Comment


      • #4
        I went in to user browseing options some members were set to get admin emails some not, so I did a sql query and updated all users to recive admin emails.

        Still not sending, it tells me it has send but nothing at the other end.

        I looked at the options table in the databse.All users have either one of these numbers in there option table.

        3927
        7511
        7671
        3415
        7767
        3159
        3415
        3159
        3671

        There might be more It would take to long to check, this is after setting allow admin emails.
        Last edited by DR€@M W€@V€R; Sat 5 Feb '05, 1:00am.

        Comment


        • #5
          This is a user option, not a usergroup one.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Yes I uderstand that I was wanting to make sure I didnt missed anything. I updated all members to 3159 in the user.options table so every one is set to get emails.

            I got a bounced email that is a good sign as it means it is working, however not everyone is getting them I have 3 other email accounts that I can check to see if the emails got there.

            I think somewhere a long the line it is getting to a limit and then just quiting sending them out. Do you recommend I ask my host about it if this is as far as you can help?

            thanks.

            Comment


            • #7
              Since some email is working, you will need to view the mail logs on the server to see what happened to those emails that don't work. Once vB sends it to PHP it's in the hands of the server. If you are on a shared server you may need to ask your host to look through the logs for you.

              For what it's worth I get a lot of bounced emails from people who's mail boxes are full, 'unavailable' or over quota. This is a particular problem with hotmail and yahoo accounts. Unless you are on a dedicated server and can set where these bounce messages go, you will never see them. The mail logs will have a record of these though.

              Another thing to keep in mind is that many ISPs and mail clients are putting in very aggressive spam filters. It's possible these emails are being placed into a spam folder or are being filtered.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                I will enquire about the mail logs from my host, I know what you are saying about the spam fillters but out of about 200+ emails getting sent maybe only a handfull are getting them.

                The mailing system worked great on vb 2.3.5 and but after the upgrade to vb3 it has not been so good. I am wondering if there is anything that might be causeing the email problems by doing the upgrade from vb2 and not just a clean vb3 install, maybe a database problem?

                Well thanks anyway...

                Comment


                • #9
                  No. As I said since some email is working, the problem is either server or mailbox related. The mail logs will tell you what is happening to these emails.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    I think the email is working fine now, thanks for the help Steve.

                    Comment


                    • #11
                      I have the same problem but according to my website host provider, it is normal to not allow bounce backs to go to the original issuer since hackers/spammers use the bounce back information for their own purposes. Does that make sense? Any ideas how I can work around it and get my bouce backs?

                      Comment

                      Related Topics

                      Collapse

                      Working...
                      X