Stuck on step 2, need help with set via MySQL Administration

  • Time
  • Show
Clear All
new posts
  • SnowPunk98
    New Member
    • Feb 2005
    • 8

    Stuck on step 2, need help with set via MySQL Administration

    I get to step 2 where it trys to connect to the database and it can't continue. I have searched many times and read a lot of documentation. I have tried creating the database and user with the command line and MySQL Administration.

    I know the server, database name, username, and password need to match that in MySQL. Normally I use MS SQL and this is my first time in MySQL. Can someone tell me how to create the database, user, and assign the proper rights to it with MySQL Administration?

    Below are the versions of everything I am running.

    Windows 2003 Server
    IIS 6.0
    PHP 4.3.10
    MySQL 4.1.9
    vBulletin 3.0.6
  • Steve Machol
    Former Customer Support Manager
    • Jul 2000
    • 154488

    What error are you getting?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography

    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    • SnowPunk98
      New Member
      • Feb 2005
      • 8

      The error message is as follows...

      The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.
      I did read many times what you said below to many people but I did check all of this.

      This error means either:

      1. One or more of the following is wrong in your config.php file:

      $servername (except in rare case, this should almost always be left as 'localhost')

      If you are unsure of what the appropriate values are then you will need to ask your web host.

      2. Or that this db user is not assigned to that database or does not have permission to access MySQL to create or access a database. You may need to first manually create the database and assign the db user to it. Since each web host is different, if you do not know how to do this then contact your web host for help.
      I think my problem is more of like assigning rights to the user for the database in MySQL Administration.


      • SnowPunk98
        New Member
        • Feb 2005
        • 8

        I don't know why this isnt working, I am even trying to connect as root which wont work. I think I have givin full access to the database but I dont know for sure. I think this might be easier to do via the command line except I dont know the commands.


        • Zachery
          Former vBulletin Support
          • Jul 2002
          • 59097

 You need to set an OLD_PASSWORD at this time for MySQL 4.1.X because php 4.3.10 does not have builtin mysqli support IIRC.


          • SnowPunk98
            New Member
            • Feb 2005
            • 8

            Thank you so much, that solved the problem.


            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.