Updated 3.0.1 to 3.0.6 - now getting Database errors

  • Time
  • Show
Clear All
new posts
  • WebMasterP
    New Member
    • Jul 2002
    • 8

    Updated 3.0.1 to 3.0.6 - now getting Database errors

    I upgraded from 3.0.1 to 3.0.6 today, now my email is getting flooded with errors.

    All have the same 1142 error number (which is the access denied error).
    Database error in vBulletin 3.0.6:

    Invalid SQL:
    UPDATE cron
    SET nextrun = 1106542560
    WHERE cronid = 2 AND nextrun = 1106535360 mysql error: update command denied to user: '[hidden]' for table 'cron'

    mysql error number: 1142

    Date: Monday 24th of January 2005 06:06:56 AM
    Script: http://www.xtremetek.com/forums/cron.php?&rand=714033
    Referer: http://www.xtremetek.com/forums/show...p?threadid=634
    Username: Unregistered
    IP Address: [hidden]

    I copied and pasted one of the SQL queries and try to execute it manually through phpMyAdmin. It also denied me permission.

    I'm posting to see if there some known issue that caused this or if I need to talk to my host.

    Just found out this is preventing me from getting into the admin console as well (decided I should go make a back up in case anything happened). This time the error arises from a permission denied to the session table.
    Last edited by WebMasterP; Sun 23 Jan '05, 8:29pm.
  • Zachery
    Former vBulletin Support
    • Jul 2002
    • 59097

    Well the update command is not allowed to your user.

    vB needs to be able to run the UPDATE command via mysql, check the permissions on the user.


    • WebMasterP
      New Member
      • Jul 2002
      • 8

      ... I believe that's what I said.

      I wanted to know why this happened right after my upgrade. vBulletin worked fine YEARS prior to today's upgrade.

      I guess I'll submit a ticket with my host, maybe they can provide some help.


      • Steve Machol
        Former Customer Support Manager
        • Jul 2000
        • 154488

        The UPDATE command is not a new requirement for vB. It sounds like the permissions for your DB user have changed. If you have CPanel you can set these permissions yourself. I'm not sure if Plesk and Ensim have the same option but I suspect they do.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography

        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.