Announcement

Collapse
No announcement yet.

Import mysql database from 3.0.3 to 3.0.6

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Import mysql database from 3.0.3 to 3.0.6

    I'm in the middle of migrating my vBulletin forums from a server with an unstable Win 2003 installation to a shiny new server/OS/etc. So, to "upgrade" to 3.0.6 , I set up an indentical server, right down to the video card and hard drives, and instaleld a new fresh copy of vB 3.0.6, MySQL 4.0.23-nt, and PHP 4.3.10. After this is all over I get to bring the old server home and reformat the disks and make it a game machine

    I set up the new vB installation *exactly* as before, same config file entries and all. Everything is on the new server is exactly as it was on the old one.

    So...I backed up my database on the old server and FTP'd it to my new server. I'm pretty much all set to import the backup to the new server, only not being an sql wiz I tried the obvious command. This is what I did and what I got:

    C:\mysql\bin>mysql -umyusername -pmypass < c:\mysql\forumbackup-01-23-05.sql
    ERROR 1046 at line 1: No Database Selected
    OK...I thought this wasn't going to 100% straightforward so I did this:


    C:\mysql\bin>mysql -umyusername -p
    Enter password: ********
    Welcome to the MySQL monitor. Commands end with ; or \g.
    Your MySQL connection id is 25 to server version: 4.0.23-nt
    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.
    mysql> use mysqldb;
    Database changed
    mysql>
    OK...now I've selected the database but now what? I can't seem to find a way to import the database backup from within MySQL.

    Usually, I'd just RTFM, but the FM is 1.2 million pages long and I don't have that much time. My current system is a ticking bomb.

    My old server runs vB 3.0.3, MySQL 4.0.22-nt, and PHP 4.3.9. I run no hacks whatsoever, just a new skin.

    Help!

    Last edited by Caravan; Sun 23 Jan '05, 11:03am.

  • #2
    When you import the database, you will need to upgrade vBulletin again...

    C:\mysql\bin>mysql -umyusername -pmypass < c:\mysql\forumbackup-01-23-05.sql
    You left out a DATABASE

    C:\mysql\bin>mysql -umyusername -pmypass DATABASENAMEHERE < c:\mysql\forumbackup-01-23-05.sql

    Comment


    • #3
      Please don't bump your posts untill at least 24 hours have past. Make sure your config.php is pointed at the right set of data, if your old forums had a prefix of vb3_ you need to add this to the config.


      As I said elier, installing 3.0.6 and using mysql to import your old 3.0.3 database, makes your forum 3.0.3 not 3.0.6

      Comment


      • #4
        I am experiencing similar issues, except that I used ImpEx to move my db from a 3.03 install to a fresh 3.06 install.

        It appears that everything came over okay, all the users are there, all the posts and threads are there, only you can't actually get to the posts.

        You click on any thread, or last post; you just go to a blank page.
        It's not even giving me an error that I can see.

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X