Announcement

Collapse
No announcement yet.

"POST requests from foreign hosts are not allowed"

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Hello,
    I have a simiar problem, but it doesn't happen for the reasons listed above. A few members are getting that same error when they try to upload directly from their computer. This is the only time I have received word of this error. I managed to locate this in my init file and wonder if it means anything to anyone? So what could be causing this error when people are trying to upload from their PC?


    PHP Code:
     if (!preg_match('#' preg_quote($http_host'#') . '$#siU'$refhost)) 
    {

    die(
    'POST requests from foreign hosts are not allowed.'); 


    Herp Center - Reptile Forums

    Comment


    • #17
      Hello,
      Someone must know the reason.
      Herp Center - Reptile Forums

      Comment


      • #18
        Same problem, I have freedom2support.net as the main domain with freedom2support.com and .co.uk as an alias of these two, if anyone tries to login to the forum from .com or .co.uk they get this message. Is there any way I can stop it, it didn't happen until very recentley.

        Comment


        • #19
          I have a same problem like a poster above, if users want to log into their accounts from other subdomain sites than forums.site.dom they get the "POST requests from foreign hosts are not allowed" the error.

          Why are vBulletin people ignoring us, I for one am not running any hacks so there no reason to go to vBulletin.org to ask for help there. vBulletin should provide the help here for us...

          Comment


          • #20
            If you have not installed any hacks (which includes portals), fill out a support ticket at:

            http://www.vbulletin.com/members/mem...ontactform.php

            Be sure to include the login info to your Admin CP, phpMyAdmin and FTP.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #21
              I edited init.php but I'm still having the same problem as the posters above...

              I can't fill out a ticket because vBindex is installed....

              Comment


              • #22
                Bump!

                Comment


                • #23
                  I was getting the same problem, with out installing any hacks
                  Robert - Music is my caffeine!

                  Comment


                  • #24
                    Why the bumping? I already said if you have not installed any hacks to fill out a support ticket. If you have installed hacks, then we cannot provide support.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #25
                      Originally posted by Steve Machol
                      Why the bumping? I already said if you have not installed any hacks to fill out a support ticket. If you have installed hacks, then we cannot provide support.
                      I was hoping someone who has fixed this could help me, but okay...

                      Comment


                      • #26
                        A quick note to others. I have several popular "vb integrated" scripts that run independently of vBulletin that use the vB user database for consolidation purposes. They do not contain any hacks of vB code. At least two of them generate the "POST requests" error when users try to login.

                        My setup is as follows:

                        www.domain.com/forums

                        www.domain.com/script/

                        If you try to login from the script directory the error message appears. This did not happen until I updated to 3.0.7.

                        I do agree with Steve that this is not, per se, an issue that directly affects the sole function of vBulletin. I do think the discussion is useful since this is a vbulletin change that probably affects a good number of sites. It will probably save many hours of frustration if people are aware of its existence.

                        ---- UPDATE

                        OK, I solved the problem. I'm not sure how you guys solved the parked domain issue, but that was the source. I have several scripts that use parked domains for each service and are separately branded. All run on the same host. classifieds.com/classifieds/ is really domain.com/classifieds and forum.com/forum is domain.com/forum.

                        If you set up your vB options to use a parked domain, you cannot do so. You must use a common domain, e.g. the forum home page entry from www.forum.com must be reset back to www.domain.com and every other common script must use the common domain. I've lost the sweet appearance of the appropriate domain (and all my customized logos for those domains) and am working on a workaround that hopefully will use an <if> statement to deal with this.

                        Steve, if you wish that we take this to vbulletin.org, I am glad to do so. I just was not sure whether this was something you may wish to take into account regarding the core product or this would now be considered an "add on."
                        Last edited by slinky; Tue 22 Mar '05, 8:56am.
                        My law forum, lawyers and legal help site

                        Comment


                        • #27
                          Why is vbulletin being so stubborn about this issue? Allowing POST requests from foreign domains was an easy fix with 3.0.5, now there seems to be no obvious work around with 3.0.7.
                          It should'nt matter if I use hacked code or not, I purchased a vbulletin license, and I should have the option to configure the software to work with my site as I see fit.

                          Comment


                          • #28
                            Stubborn? You have a right to expect support for vB. However when you alter the code, we obviously cannot be responsible for providing support to forums running code we did not write.
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #29
                              Firewall Can Be The Problem

                              if you are hosting your bb site behind a firewall that "strips" the original header from the page before passing it on to the web server, then, you can get this error. The "fix" is to change your firewall settings to pass the original page header to the "back end" web server.

                              NOTE: Microsoft Internet Security and Acceleration (ISA) Server prior to version 2004 does this by default.

                              Comment


                              • #30
                                This same error is happening to some of my users but only when they try to upload photos. They are using the same URL as everyone else because I asked them to post the URL on the page before the upload. I don't want to open up any security holes if I don't have to. By the way I am running 3.06.

                                -V

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X