Announcement

Collapse
No announcement yet.

v3.0.5 error: POST requests from foreign hosts are not allowed.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • v3.0.5 error: POST requests from foreign hosts are not allowed.

    After updating last night to v3.0.5 I and many of my members get the following error when posting:

    POST requests from foreign hosts are not allowed.

    This is due to the fact that the forum links do not correctly point to the subdomain where the server resides.

    The server is on forums.audioholics.com/forums (a separate server) and the links all point to www.audioholics.com/forums

    Can anyone please help me understand where to go to resolve this problem?

  • #2
    Check your Forum URL;
    AdminCP > vBulletin Options > Help Site Name / URL / Contact Details > Forum URL

    It should point to forums.audioholics.com/forums (according to your post).

    Comment


    • #3
      I checked that and it's now correct...

      OK, after some more digging, it appears that the domain forwarding we have in place is no longer working for vBulletin. i.e. we enabled www.audioholics.com/forums - to forward to the other server (forums.audioholcis.com/forums) - whereas now we get the error if this happens and a followup post is initiated.

      So essentially - the error seems to be happening to people who have an old bookmark (which worked prior to the update)

      The v3.0.5 seems to no longer allow people to post from a different sbdomain, even if it has forwarding set up on the server. I wonder if this is part of the securoty patch or if there's a way to fix this rather than lose the ability to intuitively follow up on old Google links and such.

      Comment


      • #4
        It is security related, but you can disable it by placing:
        Code:
        define('SKIP_REFERRER_CHECK', true);
        in your config.php.

        Though IMO, the best way would be to just forward requests to www/forums to forums/forums via mod_rewrite.

        Comment


        • #5
          i get the error "disable function not found"... help please?

          Comment


          • #6
            Mike meant to say:
            PHP Code:
            define('SKIP_REFERRER_CHECK'true); 

            Comment


            • #7
              ...And now I did.

              Comment


              • #8
                You guys are great... the mod_rewrite is what solved it for us.

                Comment


                • #9
                  Can I ask how one achieves this via mod_rewrite please... ta
                  John

                  Comment


                  • #10
                    I have a user experiencing this error message as well but I have no forwards or anything like that in place. Site is correct in the admincp. No hacks. What else could cause this for someone?
                    Deron
                    www.creationnation.com
                    www.ultimatemetal.com

                    Comment


                    • #11
                      http://www.modrewrite.com their are links too 2 forums their.
                      Chris Edwards

                      Chattanooga Online Community

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X