Announcement

Collapse
No announcement yet.

Error after upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error after upgrade

    I have upgraded from 3.0.3 to 3.0.5 and get this error when I'm trying to to open a forum from the first page.

    Invalid SQL:
    SELECT threadid
    FROM vb3_thread AS thread

    WHERE forumid = 105
    AND sticky = 0
    AND visible = 1

    AND lastpost >= 1102750964


    ORDER BY sticky DESC, lastpost DESC
    LIMIT 0,

    mysql error: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 12
    mysql error number: 1064

    Date: Monday 10th of January 2005 08:42:44 AM
    Script: http://www.zpet.se/forum/forumdisplay.php?f=105
    Referer: http://www.zpet.se/forum/
    Username: admin

  • #2
    Could you PrivMsg me your admin account and the ftp account? Then I can look into this and try to determine what went wrong.

    Comment


    • #3
      Something appears to be definitly wrong as the vbulletin options don't go any further then forum display options and isn't showing the admin or paid subscriptions options for example.

      Did you have any hacks installed before you upgraded?

      Comment


      • #4
        Webpage & Guestbook Script ( http://www.vbulletin.org/forum/searc...earchid=907773 )
        vbJournal ( http://www.vbulletin.org/forum/showt...hlight=journal )

        was installed.

        Comment


        • #5
          I'm not sure if this could be caused by those scripts. I uploaded the original files that reported an error and that didn't make it go away. I tried a default style and that didn't help. I can't find something funny with the thread table. So I am out of guesses here right now. But as things are incomplete, I think there could be database corruption or at least tables or data that is broken.

          You can try make a new support ticket and someone else from our staff could take a look for you. But please realize that we do not support custom code. So our help can only go as far as finding out what is wrong where.

          Comment


          • #6
            I'll restore 3.0.3 and the tables from that backup.

            Comment


            • #7
              ... but if the hacks doen't do any table changes? I allways upload original files and then add the hacks. The original files where there when I did the upgrade.

              Comment


              • #8
                Did you re-upload all the files in ASCII transfer mode, making sure they are 100% uploaded? Overwriting the files already there, not resuming or skipping them? Does it still happen?

                Comment


                • #9
                  When I run:

                  SELECT threadid
                  FROM vb3_thread AS thread

                  WHERE forumid = 105
                  AND sticky = 0
                  AND visible = 1

                  AND lastpost >= 1102764743


                  ORDER BY sticky DESC, lastpost DESC
                  LIMIT 0;

                  in phpMyAdmin it works correctly. I had thou to change LIMIT 0, to LIMIT 0;

                  Comment


                  • #10
                    I usally use AUTO in the ftp program. Now I have put it to ASCII.

                    1/ I delete forum directory
                    2/ Uploaded it again using ASCII only

                    Same problem

                    Comment


                    • #11
                      I got help from your support:

                      "I'm not quite sure how this happened but the 'maxthread' vB option hadn't been set in the settings table. The settings have been re-imported and the forums are now back."

                      This fixed it.

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X