Announcement

Collapse
No announcement yet.

Attachements broken after server move? Read this!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachements broken after server move? Read this!

    Hats off to Steve for his diligence and patience with me as we tried to uncover what was wrong.

    Problem: After moving servers, all previous attachments were coming up as a blank white screen, and no attachments could be uploaded.

    Reason: Buried in the database is the server path that attachments are contained and moved to. If your new server config has a different path, you have trouble!

    Example

    old server: /home/virtual/sitename/www/html/forums/attachments
    new server: /home/html/forums/attachments

    Solution: Manually editing the path in the database is necessary. DO NOT ATTEMPT TO EDIT THIS WITHOUT BACKING UP YOUR DATABASE FIRST. NOT RECOMMENDED FOR PEOPLE UNFAMILIAR WITH MYSQL Submit a support ticket for help if you do not know how to make changes in your database without step by step instructions

    Thank you so much Steve for spending 2 days on this with me. Not an easy problem to diagnose. My users and I truly appreciate your patience and commitment to fixing this very tricky issue.
    www.karmicpower.com
    online community of like minded people

    be the change you wish to see in the world

  • #2
    I have this exact issue. Does anyone know where this setting can be found in the database?
    Mike Warner
    MIGWeb - a Vauxhall Site for Enthusiasts of all Vauxhalls

    Comment


    • #3
      I just found this in the user manual.
      If you wish to move attachments to a new directory, choose the Move Items to a Different Directory option and press [Go]. You will be presented with a screen asking your for a pathname, displaying the current attachment directory. Enter your new directory and press [Ok].

      Note:
      This step does not create the new directory, nor does it actually move the attachments. It simply changes the directory that vBulletin looks for attachments in. You must create the directory, give it proper permissions (as detailed in the previous section), and then move the attachments manually.
      I take it this means I can change the path in the admin CP then?

      Cheers for any help.
      Mike Warner
      MIGWeb - a Vauxhall Site for Enthusiasts of all Vauxhalls

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X