Announcement

Collapse
No announcement yet.

internal server error (vb 3.0.4)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • internal server error (vb 3.0.4)

    Hello, i recently upgraded to 3.0.4 and i'm having problems updating some templates. Currently my board is un-hacked besides a portal (vbindex) and no changes were made to any files except for /admincp/index.php where i added a nav option for the portal.

    My problem is that everytime i try and update a template, i get an internal server error. I read that it might have something to do with mod_security, could someone please explain why?

    Here is the error i get when trying to update...
    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request. Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.



    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    i've double and triple checked every file on my server and they are all current versions (looked at date changes)

    Thanks for your time and i hope you can help soon. Btw, my board runs fine except for the fact that i cant update templates.

  • #2
    ASk your host to uninstall mod_security

    Comment


    • #3
      Originally posted by Zachery
      ASk your host to uninstall mod_security
      can i get a list of changes that would have caused vbulletin and mod_security to not work well together?

      And, is there any other possible reasons it could not be working?

      Comment


      • #4
        What modifications need to be made to mod_security in order for it to work?! my host wont remove it.

        Comment


        • #5
          Not sure, I've never personaly used it, there are no changes in vBulletin that would cause it to not work with mod_security, mod_security itself has an issue with some things vBulletin does.

          Might want to look for a new host

          Comment


          • #6
            Originally posted by Zachery
            Not sure, I've never personaly used it, there are no changes in vBulletin that would cause it to not work with mod_security, mod_security itself has an issue with some things vBulletin does.

            Might want to look for a new host
            Well thanks anyways. I think it has to do with how many ≶ And > (or foreign characters) are passed through a form that is causing the error. Becuase on smaller templates i am still able to update thing just fine.

            Just a thought, instead of having the template system change the &lg; and &gt; back to < > in the edit box, why not use <pre> tags, or other escaping tags so the code doesnt get parsed in html when your making your template edits. I had no problems with this before 3.0.4, did they make any changes to the template system and how it worked besides visually? (it might have been the new php upgrade, but i thought i had edited fairly large templates before that).

            Comment


            • #7
              I bet you anything your host installed mod_security after upgrading to a new version of php, there have been no changes to vBulletins template system as of late AFAIK.

              Comment


              • #8
                Originally posted by Zachery
                ASk your host to uninstall mod_security
                I have not mod_security installed and i'm getting the same trouble.

                My site ir in www.webconferencia.net (public php info = On)

                Can you help me please?

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X