Announcement

Collapse
No announcement yet.

MySQL problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MySQL problems

    On my host, I have created:

    a database called wishcomm_vb
    a user called wishcomm_vbuser
    and the password for wishcomm_vbuser is temp.

    I gave vbuser all privilages for wishcomm_vb.

    On step three of the installation process, I get this:

    Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in /usr/home/wishcomm/public_html/includes/db_mysql.php on line 140
    The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.


    Here is a condensed version of my config.php:

    <?php
    $servername = 'localhost';
    $dbusername = 'wishcomm_vbuser';
    $dbpassword = 'temp';
    $dbname = 'wishcomm_vb';
    $technicalemail = '[email protected]';
    $usepconnect = 0;
    $admincpdir = 'admincp';
    $modcpdir = 'modcp';
    $canviewadminlog = '1';
    $canpruneadminlog = '1';
    $canrunqueries = '';
    $undeletableusers = '';
    $superadministrators = '';
    $tableprefix = 'vb3_';
    $cookieprefix = 'bb';

    ?>

    What in the heck is the problem here?
    Last edited by digeraticular; Thu 30 Dec '04, 9:47am.

  • #2
    This error means either:

    1. One or more of the following is wrong in your config.php file:

    $servername (except in rare case, this should almost always be left as 'localhost')
    $dbusername
    $dbpassword
    $dbname

    If you are unsure of what the appropriate values are then you will need to ask your web host.

    2. Or that this db user is not assigned to that database or does not have permission to access MySQL to create or access a database. You may need to first manually create the database and assign the db user to it. Since each web host is different, if you do not know how to do this then contact your web host for help.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X