Announcement

Collapse
No announcement yet.

Sendmail Not Working For VB3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sendmail Not Working For VB3

    Hello,

    Odd thing is that Sendmail works for phpBB fine, that's the board I just upgraded from, I even went back to it to send another mail. When an email gets sent from VB3 it simply sits in the mail queue, I've got an example from the log...

    Dec 24 00:49:20 brasil sendmail[930]: iBO0nKEV000930: [email protected], ctladdr=apache (48/48), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30395, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (iBO0nKPx000932 Message accepted for delivery)
    Dec 24 00:49:20 brasil sendmail[934]: iBO0nKPx000932: to=<[email protected]>, ctladdr= (48/48), delay=00:00:00, xdelay=00:00:00, mailer=esmtp, pri=30535, relay=mk-mx-2.b2b.uk.tiscali.com. [212.74.112.76], dsn=4.0.0, stat=Deferred: Connection reset by mk-mx-2.b2b.uk.tiscali.com.
    Everything seems to be set up as sendmail also works for a webpage that allows users to submit forms via sendmail. You can see from the end of the log the error...

    Connection reset by mk-mx-2.b2b.uk.tiscali.com.

    I've also had...

    reply: read error from mk-mx-1.b2b.uk.tiscali.com

    As I said this only happens from VB3 but obviously the messages are getting to Sendmail just nothing likes them when they try to send?

    Sendmail in PHP info

    sendmail_from [email protected]
    sendmail_path /usr/sbin/sendmail -t -i

    At this point in time I am going into the messages in Sendmail copying and pasting them into my email client and sending them manually

    Any suggestions?

  • #2
    There have been loads of people who have reported problems using SendMail. Here is a link that might be helpful.
    Gerry

    Comment


    • #3
      Try this to see if it helps

      Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Enable "-f" Parameter -> Yes

      Other than that I really don't know what else to suggest. As you noted, vB is sending these emails to the server.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        The -f option didn't work. I've removed Sendmail and reinstalled it, everything else works with it but the VB3 Still getting...

        Running /var/spool/mqueue/iBOAhWhP003422 (sequence 2 of 2)
        <[email protected]>... Deferred: Connection reset by mk-mx-1.b2b.uk.tiscali.com.
        Closing connection to mk-mx-1.b2b.uk.tiscali.com.

        I feel a bit stuck here.

        Comment


        • #5
          Which version of vBulletin do you use?
          Could you please try:
          Admin Control Panel > vBulletin Options > vBulletin Options > Server Settings and Optimization Options :

          Use Mailqueue System : NO
          Enable "-f" Parameter : YES (and if that not works, then try with NO again)

          So we can see if the mailqueue system could be causing this.

          Comment


          • #6
            Do a Google search for:

            Deferred: Connection reset

            There seems to be a lot of results.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I have been Googling this one unfortunately none of them have been able to properly incorporate my stupidity, I changed the smtp address to my ISPs but never uncommented the line, I didn't appreciate what dnl meant at the start of the line so it now reads..

              define(`SMART_HOST',`smtp.myprovider.com')

              ...rather than...

              dnl define(`SMART_HOST',`smtp.ox.ac.uk')

              Maybe this will help someone else when looking through this board.

              I guess my server was trying to deliver mail directly, I was wondering why I was getting messages from other domains MXs, I thought the message was being relayed via my ISPs SMTP server.

              Thanks for the everyone.

              Comment


              • #8
                Delay Email

                This may belong in another thread but I can't find anything doing a search so here it goes..

                Is there a way to delay email from being sent once a reply to a thread has been made?

                Here is the problem:
                A user either creates or replies to a thread:
                The user summits the thread and then discovers spelling or other typo's
                The user then edits the message and corrects the error's

                The problem is that the email is sent using the orginal message, if there was or if there is a way to delay the email sent for X miniutes after the edited message is summited would solve the problem.

                Maybe there is a way to do this, I just can't find it...

                Thanks in advanced for anyone with help

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X