Announcement

Collapse
No announcement yet.

Upgrade-issue; mistake in upgrade5.php?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Upgrade-issue; mistake in upgrade5.php?

    I was upgrading my board from vB2 to vB3 and ran into a couple op probs. Nothing i couldn't solve.

    However one issue gave me a syntax-error (i use MySQL 4.1). On line 144/145 in upgrade5.php it states the following:
    ALTER TABLE " . TABLE_PREFIX . "user
    ADD autosubscribe SMALLINT NOT NULL DEFAULT -1

    After changing -1 into \"-1\" it worked. Is this a mistake or did i make 1?


    Same problem in upgrade6.php; i think in every file that hasn't got the quotes around the default-value.
    Last edited by marocnl; Sat 11 Dec '04, 10:27am. Reason: added the remark about other files
    :rolleyes: :eek::eek::eek::eek::eek::eek::eek::eek: :rolleyes:

  • #2
    At this time we are not recomending use of MySQL 4.1.X. Try downgrading to MySQL 4.0.20/22 and see if the issue goes away

    Comment


    • #3
      Originally posted by Zachery
      At this time we are not recomending use of MySQL 4.1.X. Try downgrading to MySQL 4.0.20/22 and see if the issue goes away
      I solved this by putting quotes around it. Unless the quotes are missing in other places in the actual php-files of vB3, i'll just stick with 4.1. Almost finished upgrading...i'll just test it. And who knows, maybe you can use the feedback. It's just a test-environment.
      :rolleyes: :eek::eek::eek::eek::eek::eek::eek::eek: :rolleyes:

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X