Announcement

Collapse
No announcement yet.

Error when loading large attatchment

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error when loading large attatchment

    When I try an attatchment more than 10MB or so, the upload page goes blank after a few min of uploading, and I get a huge email with an error and the attachment sent back:

    Invalid SQL:
    INSERT INTO attachment
    (userid, dateline, filename, filedata, filesize, visible, filehash, posthash, thumbnail, thumbnail_dateline, thumbnail_filesize)
    VALUES
    (3, 1102685292, 'musclebossanova.wmv'

  • #2
    First, check your attachment size setting in the Admin CP and make sure it's large enough. If that is fine, then you need to change the upload size for both PHP and for MySQL. You need to have root access to the server to do this. Make these changes to php.ini:

    upload_max_filesize = xM

    ..and my.cnf

    set-variable=max_allowed_packet=xM

    Change it to the size ('x') you want in Megabytes. Restart the webserver and MySQL after making these changes.

    Note: You may also need to increase the max_execution_time and max_input_time variables in php.ini.

    Also you might want to take a look at this for other settings that affect file uploads:

    http://www.vbulletin.com/forum/showp...0&postcount=12
    http://www.vbulletin.com/forum/showt...319#post748319
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Thank you!

      Comment


      • #4
        OK, I'm on a new box, and I'm having this problem again. I have gone through all the settings mentioned in this thread and the links provided - yet it still happens - help!

        Comment


        • #5
          Those are all the settings I know of that will affect file uploads. How large is this file?
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Well, I have used several test files. Everything up to about 16MB works, fine.

            Comment


            • #7
              Then realistically that is your upper limit.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Yes...but on my old box, it wasn't, it was 200. I have set everything back to 200, I just don't know what I'm missing - obviously something is still limiting me.

                Comment


                • #9
                  bump

                  Comment


                  • #10
                    Sorry but I have already posted all the settings I know of that would affect this.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X