Announcement

Collapse
No announcement yet.

problem uploading avatars

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • problem uploading avatars

    I am trying to upload an avatar and I get this error:
    Warning: copy(): open_basedir restriction in effect. File(/var/tmp/phpXkV8Hn) is not within the allowed path(s): (/usr/home/mywebsite:/usr/lib/php:/usr/local/lib/php:/tmp) in /usr/home/mywebsite/public_html/admincp/image.php on line 444

    Any ideas? I run under Freebsd.

  • #2
    In the Admin CP, open the Server Settings and Optimization Options section and turn on the Public phpinfo() Display Enabled setting. Then provide the URL to your forums. This may help us troubleshoot this problem.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Sounds like the directory you're attempting to place the avatars into is not one you have access to by your site host.

      Comment


      • #4
        Steve -- Open de server settings and optimization options --- I can not find that option, where is it? maybe here: mywebsite.com/admincp ??? I did not understand anything on your message, do you wanna see my phpinfo()?

        Comment


        • #5
          Dennis, the directory where I wanna place my avatars into is ./images/avatars and I chmodded to 777

          Comment


          • #6
            Yes, I need to see your phpinfo page. I thought I explained how to enable this in post #2. This is in the vBulletin Options.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Don't use the "."

              Just "images/avatars"

              Comment


              • #8
                He still has open_basedir restrictions and uploads need to go to an acceptable temporary directory first. This is why I need to look at phpinfo.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Gotcha.

                  Comment


                  • #10
                    Dennis, Im not using the "."
                    Steve, thanks for cheking my problem, I pm'ed you the phpinfo link

                    Comment


                    • #11
                      In the future, please don't PM me unless I ask. I handle hundreds of issues every day and it just makes it more difficult. If you need confidentiality, please use the support system.

                      You have open_basedir restrictions on your server. To get uploads to work you need to create a 'tmp' subdirectory under your main site directory and chmod it to 777. Then in the Admin CP set "Upload In Safe Mode?" to 'Yes' and point the "Safe Mode Temp Directory" to that directory. If you placed the tmp directory in the right place, the path to the Safe Mode Temp Directory will be:

                      /usr/home/vlad7x/tmp
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        my open basedir line goes like this:

                        open_base dir/usr/home/myhostacc:/usr/lib/php:/usr/local/lib/php:/tmp no value

                        Comment


                        • #13
                          sorry for my pm, it wont happen again, im still a noob
                          Anyway it did work! thank you very much, what a great support! I just have a last question, is there any problem if my tmp folder is localed in the public html here /usr/home/vlad7x/public_html/tmp instead of outsite of the public /usr/home/vlad7x/tmp?
                          Thank you!

                          Comment


                          • #14
                            Generally it's better to keep this out of the web directories so I'd recommend using:

                            /usr/home/vlad7x/tmp
                            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                            Change CKEditor Colors to Match Style (for 4.1.4 and above)

                            Steve Machol Photography


                            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                            Comment


                            • #15
                              Originally posted by Steve Machol
                              Generally it's better to keep this out of the web directories so I'd recommend using:

                              /usr/home/vlad7x/tmp
                              ok I have a folder now outside of the public html, but its called temp instead of tmp, I assume there is no problem with that, right?

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X