Announcement

Collapse
No announcement yet.

Attachment error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachment error

    Hello I was trying to upload an attachment to my site and got an error, it was a zip file that is 1.13 MB (1,187,840 bytes). Below is from the email that was sent to me, because of it:
    Database error in vBulletin 3.0.3:

    Invalid SQL:
    INSERT INTO attachment
    (userid, dateline, filename, filedata, filesize, visible, filehash, posthash, thumbnail, thumbnail_dateline, thumbnail_filesize)
    VALUES
    (1, 1101860123, 'qlock144.zip',

    <a huge about of code for the zip....>

    mysql error: Got a packet bigger than 'max_allowed_packet'

    mysql error number: 1153

    Date: Tuesday 30th of November 2004 07:15:24 PM
    Script: http://www.4xtraders.com/forum/newattachment.php
    Referer: http://www.4xtraders.com/forum/newat...3965c807d1980b
    Username: TraderX
    IP Address: 67.165.116.159
    I did increase the zip attachment size and also increased the Admin attachment size, and tried to upload it a few times and got the same errror.

    Let me know if I need to post any more info.
    Thanks

  • #2
    This is a MySQL limit. You or your host need to increase this setting in my.cnf:

    set-variable=max_allowed_packet=xM

    Change it to the size ('x') you want in Megabytes. Restart MySQL after making these changes.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Thanks for the quick reply Steve... I asked my host and they said that they wouldn't be able to... so thats a bummer, but thanks

      Comment


      • #4
        1mb is really too small, they should be able to raise it to at least 4 or 8 if not 16.

        Comment


        • #5
          Originally posted by plan_b
          Thanks for the quick reply Steve... I asked my host and they said that they wouldn't be able to... so thats a bummer, but thanks
          may i ask who is your web host ? ideally even for shared servers by web hosts max_allowed_packet should be optimally set at 16M
          :: Always Back Up Forum Database + Attachments BEFORE upgrading !
          :: Nginx SPDY SSL - World Flags Demo [video results]
          :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

          Comment


          • #6
            www.onsmart.com
            The guy I talked to with their live chat (24/7) just said that 'he' couldn't do it, and that the 'admin' was not there. That by changing the config would change it for the whole server (so what, like you said, 1mb seems pretty small).

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X