Announcement

Collapse
No announcement yet.

Adding Menu

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    hmmmm I found a different menu that I could use what only uses a js file and a html file. I was never able to get that last one to show, so I started smaller.

    I made a test.html and then went to the phpinclude_start template and added:
    Code:
    ob_start();
    require("test.html");
    $treemenu = ob_get_contents();
    ob_end_clean();
    test.htm only had treemenu in it but I was able to get it to show up where I wanted. So I moved up to use the html page that had the menutree in, but it does nothing, and I put every thing in /forum

    If I was to post every thing I did you could you point out with I did wrong, this only needs 3 files... menu.html, jsmenu.js, style.css... I think I can not use the css file.

    I am willing to try ANY THING to get this one to work

    Coll

    Comment


    • #17
      I don't know why it's not working. You might try posting in the PHP / MySQL / JS / (X)HTML forum on www.vbulletin.org. I usually have good luck over there when I have problems with implementing code.

      Comment


      • #18
        I am working on a different menu that I have been able to work. Ya any good with java script

        I do have a question about the chat popup link:
        HTML Code:
        <a href="#" onClick="window.open('$vboptions[bburl]/chat/index.php?do=small','key','WIDTH=750,HEIGHT=500,scrollbars=no,left=50,top=50,screenX=50,screenY=50');return false">Chat(Popup)</a>
        but below is what is working it this menu:
        HTML Code:
        d.add(2,1,'Chat','$vboptions[bburl]/chat/index.php?$session[sessionurl]');
        When I put the orginal link in, it makes the menu not show up, I was wondering if there would be a way to rewrite it, to get the popup to work in the menu that I am using. I have no clue about java and don't know if the above is one that will only work for the chat in vb

        Comment


        • #19
          Originally posted by plan_b
          Ya any good with java script
          Nope.

          Comment


          • #20
            Ok... I had a menu working from my forum directory and I want it to work from www.site.com.

            it uses a menu.html, dtree.css, dtree.js, and a folder for the images

            This is all of the items that I can remember adding to the templates to get it to work the first time... I have changed them to what I think would work out side of /forum.... and help to get this to work out side of it, have I forgot something?

            headinclude:
            Code:
            <!-- begin treemenu -->
            	<link rel="StyleSheet" href="/home/jaxen/public_html/4xtraders/dtree.css" type="text/css" />
            	<script type="text/javascript" src="/home/jaxen/public_html/4xtraders/dtree.js"></script>
            <!-- end treemenu -->
            phpinclude_start
            Code:
            ob_start();
            require("/home/jaxen/public_html/4xtraders/menu.html");
            $treemenu = ob_get_contents();
            ob_end_clean();

            Comment


            • #21
              You need to use web paths in the hrefs, not server paths. The web root starts in public_html, so start from there:

              Code:
              <!-- begin treemenu -->
              	<link rel="StyleSheet" href="/4xtraders/dtree.css" type="text/css" />
              	<script type="text/javascript" src="/4xtraders/dtree.js"></script>
              <!-- end treemenu -->

              Comment


              • #22
                whats weird is that I removed it completely from my headinclude and it still worked, but now I am finding that while in /forum it creates my 'HOME' link to be http://www.4xtraders.com/forum/www.4xtraders.com when I only want it to point to www.4xtraders.com.

                It also does it with the code above

                Now just need to figure why it does this, because if I just access www.4xtraders.com/menu.html it does work fine

                Comment


                • #23
                  Originally posted by plan_b
                  ...but now I am finding that while in /forum it creates my 'HOME' link to be http://www.4xtraders.com/forum/www.4xtraders.com when I only want it to point to www.4xtraders.com.
                  That usually means you are using "www.domain.com" where you should be using "http://www.domain.com/".

                  Comment


                  • #24
                    damn your good

                    Thanks

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X