Announcement

Collapse
No announcement yet.

Vbulletin Email Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Vbulletin Email Problem

    I am not able to send emails to any other domains except the one on which it is installed.

    While carrying out the diagonstics for email, the mail was send correctly when the domain was same that of place where forum is currently running.

    But whenI tried to send mail to any other address on yahoo, gmail or other domain ..
    It gave out following error ...

    ---------

    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    [email protected]
    unrouteable mail domain "gmail.com"

    ---------------

  • #2
    This is a server issue, your host needs to allow email to be sent from nobody. Your host will need to make this change in WHM,

    Comment


    • #3
      Originally posted by Zachery
      This is a server issue, your host needs to allow email to be sent from nobody. Your host will need to make this change in WHM,
      Can you tell me a bit more.. what should I request to my server guys...
      Last edited by nandini; Wed 10 Nov '04, 8:02am.

      Comment


      • #4
        Take a look and direct them at this post

        http://www.vbulletin.com/forum/showp...6&postcount=20

        Comment


        • #5
          I myself have access to Webhost manager. The site is running cpanel.

          Can I do something there..
          But I am unable to find tweek settings there...

          Thanks..

          Comment


          • #6
            I have talked to my servery guys, they say they just can`t allow nobody to send mails.. This will start spamming on their servers...

            So if can`t allow nobody to send mails.. is this mean we can`t use email notification for vBulletin or is their any other hack available to overcome this problem...

            Comment


            • #7
              Please ..can somebody help me out...

              Comment


              • #8
                This is a server configuration problem. Read this:

                http://www.vbulletin.com/forum/showp...6&postcount=20

                If your host is unwiulling to make the necessary changes then I don't know how to overcome this server limitation.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  I don`t think most of the server people allow sending mails from nobody, it will start spamming if its on shared hosting...

                  But anyway does any one know any good hosts for vBulletin...
                  Or moving to dedicated servers is the only solution...

                  Comment


                  • #10
                    I've been with 2 hosts, myself and viperhost (now gone and disolved sadly) viperhost had never limited thsi and we never had an issue with spam.


                    If you are looking for a new host or want to you should try the vBulletin hosting forum and provide the specs that you need so users can help with a recomendation.

                    Comment


                    • #11
                      I would have really appreciated if you could have suggested me a solution rather than blaming it on server people..

                      This problem is faced by many users..
                      And its solution is not what is suggested by Steve Macgol in thread he pointed out..
                      Prevent the user 'nobody' from sending out mail to remote addresses (php and cgi scripts generally run as nobody if you are not using phpsuexec and suexec respectively.)
                      Don`t allow nobody to send mail.. Just make an email address with the address you have confugured intially while installing VB. PHP in vBulletin doesn`t send mail through nobody but through the mail address you created while installing the software..

                      And it will work...

                      Comment


                      • #12
                        Unfortunately this is a server configuration issue. There is nothing that vB can do to overcome this.

                        And vB does not send email as 'nobody'. Look at the 'From' address of every email you receive from a vB forum.
                        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                        Change CKEditor Colors to Match Style (for 4.1.4 and above)

                        Steve Machol Photography


                        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                        Comment


                        • #13
                          Originally posted by Steve Machol
                          Unfortunately this is a server configuration issue. There is nothing that vB can do to overcome this.

                          And vB does not send email as 'nobody'. Look at the 'From' address of every email you receive from a vB forum.
                          Exactly.. VB doesn`t send mail from nobody.. but the link you gave me said this...

                          Hey mate...

                          I sent this to ya via pm, but I thought it may prove usefull to others here as well!

                          Quote:

                          I checked with the folks that manage are server, and this is what they did.

                          If you are using WHM/Cpanel for yours, then under WHM you will find under "tweek settings", this option Quote:
                          Prevent the user 'nobody' from sending out mail to remote addresses (php and cgi scripts generally run as nobody if you are not using phpsuexec and suexec respectively.)
                          Uncheck that option and that will allow the mails to go through.

                          Regards,

                          Illu

                          Comment


                          • #14
                            Anyways all well , thats end well..
                            But its my suggestion next time someone came out with similar proble, tell tehm to make an account what they have used as main email for administrator, and ask them to make it on the same domain name...

                            Comment


                            • #15
                              I sure wish this was something fixable.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X