Announcement

Collapse
No announcement yet.

Lost mySql tables

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lost mySql tables

    Hi all, tonight my vBulletin forum had some problems. I haven't figure it out yet what's happen, but as a result i lost the following two tables:

    vb3_attachmentviews
    vb3_threadviews

    Now, I'm not an expert in this field, so I would like to know how do I proceed to fix my board.

    Also , if I got in the Admin CP, and try to go into the import/export tab, I get this error:

    Database error in vBulletin:ImpEx Target 3.0.3:

    cannot use database rg3_vBulletin
    mysql error: Access denied for user: '[email protected]' to database 'rg3_vBulletin'

    mysql error number: 1044

    (I've changed the real username)
    But I know I can connect to the DB with taht user name, since I've tried to ssh

    Thanks,
    Alex Ongaro

  • #2
    A. Run these queries to recreate these tables (assuming you have no table prefix):

    CREATE TABLE attachmentviews (
    attachmentid INT UNSIGNED NOT NULL DEFAULT '0',
    KEY postid (attachmentid)
    );


    CREATE TABLE threadviews (
    threadid INT UNSIGNED NOT NULL DEFAULT '0',
    KEY threadid (threadid)
    );



    B. This error means either:
    1. One or more of the following is wrong in your config.php file:

    $servername (except in rare case, this should almost always be left as 'localhost')
    $dbusername
    $dbpassword
    $dbname

    If you are unsure of what the appropriate values are then you will need to ask your web host.

    2. Or that this db user is not assigned to that database or does not have permission to access MySQL. Since each web host is different, if you do not know how to do this then contact
    your web host for help.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Hey thanks for the reply, but regarding the access error, I'm pretty sure everything is correct since it worked until yesterday. Also this morning I've tried to connect to my DB through ssh and mysql and everything worked fine.

      I will run the queries tonight and let you know, since now I'm proxied and can't connect to my web server.

      Comment


      • #4
        It happens again, like the last time, I have problems with the following tables:

        vb3_threadviews
        vb3_attachmentviews

        Mysql says the two tables are in use, and I don't understand why this happens. Droping them and recrete them will fix the problem but I really would like to know if anybody else has evere experienced the same problem.

        Thaks,
        Alex

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X