Announcement

Collapse
No announcement yet.

Invalid Post Specified while uploading attachment

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Invalid Post Specified while uploading attachment

    I have gone through this entire forum to see if someone else has reported this, but couldn't find anything so here goes.

    The problem I have sounds similar to other forum owners problem but produces the message
    Invalid Post Specified, if you followed a valid link, pleae notify the webmaster
    This error occurs when I try to upload a file of ANY type that is greater than 992 Kb.
    As per the various other thread's instructions I have opened and edited my php.ini file and increased various suggested upload variables as shown below

    post_max_size = 12M
    upload_max_filesize = 8M
    memory_limit = 16M

    and in my.cnf:
    set-variable = max_allowed_packet=8M

    After all this I dutifully restarted the server but alas, the problem persists.

    I run Linux 9 (shrike) vb 3.0.3 on a celeron (unreal huh, but that is what this dedicated server has, with 512 Mb memory and a 60 Gb hard drive.
    The one major difference between servers just running Linux and this dedicated server is that the latter also has something called Plesk 6.0 which does mess with the operating system and with sql. Unfortunately I have no idea what that is.

    Any ideas are most welcome and will be most appreciated.

  • #2
    What's the URL to your forums? Have you installed any hacks? Have you tried using the original vB files and templates to see if you have the same problem?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      URL = http://www.polinco.net/forum

      I am a registered lifetime owner and the forum is in pristine condition, No hacks of any kind have been applied at this time.

      Comment


      • #4
        You may also need to increase the max_execution_time and max_input_time variables in php.ini.

        Also you might want to take a look at this for other settings that affect file uploads:

        http://www.vbulletin.com/forum/showp...0&postcount=12
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Apache also has limits on maximum POST sizes. Have you checked those (the name escapes me)?

          Comment


          • #6
            Originally posted by TheHideOutGuy
            It is also possible for apache to be set to reject posts of a certain size or greater. I believe, if memory serves me correctly the directive LimitRequestBody which can be found in your httpd.conf file.
            I do not have a LimitRequestBody in my httpd.conf.

            Any suggestions as to what I should set those max_execution_time and max_input_time variables in php.ini to?

            On second thought, I only have the variable
            max_execution_time = 30

            I don't have one called max_input_time

            Where would that go?

            <edit>I found the following well-presented page: PHP Upload Configuration that might be of interest to others reading this thread. I am now applying the things I learn here and shall report my findings forthwith. Steve, Freddie, if you find additional helpful info, please do not hesitate to add that here, I do appreciate any help you can give, thanks so much! </edit>
            Last edited by Polinco; Tue 12th Oct '04, 12:39pm.

            Comment


            • #7
              Success!

              Steve, Freddie, I have gotten it to work now, thank you.

              The following info applies to servers with Red Hat 9.0 OS.

              After I had already changed the following parameters in /etc/php.ini
              post_max_size = 12M
              upload_max_filesize = 8M
              memory_limit = 16M

              and added this line in /etc/my.cnf:
              set-variable = max_allowed_packet=8M...

              things still didn't work. The link I posted above showed that there was a third file to be edited, namely /etc/httpd/conf.d/php.conf
              It is THIS file that contains the directive LimitRequestBody and it is set to a default of 524288 (512kb) I changed it to 8388608 (8Mb)

              Now it works.

              Hope this helps anyone else with this pesky problem, and perhaps someday this info, which thoroughly overrides anything one can set in the Admin Control Panel, might find its way into the user manual.

              Goodday all!

              Comment


              • #8
                I am unable to make MySQL configure correctly the max_allowed_packet. I hvae the following lines in my /etc/my.cnf file:
                Code:
                  [mysqld]
                  datadir=/var/lib/mysql
                  socket=/var/lib/mysql/mysql.sock
                  
                  [mysql.server]
                  user=mysql
                  basedir=/var/lib
                  
                  [safe_mysqld]
                  err-log=/var/log/mysqld.log
                  pid-file=/var/run/mysqld/mysqld.pid
                Where do you suggest to put the 'set-variable = max_allowed_packet=8M' directive? I tried to put it at the end of the file, restarted MySQL but still I have set 1048576 as max_allowed_packet.

                Thank you in advance.

                Fab.
                Virtual Sheet Music®, Inc.
                Classical Sheet Music Downloads®
                http://www.virtualsheetmusic.com

                Comment


                • #9
                  Originally posted by fablau
                  Where do you suggest to put the 'set-variable = max_allowed_packet=8M' directive?
                  Place it under the [mysqld] section:

                  [mysqld]
                  datadir=/var/lib/mysql
                  socket=/var/lib/mysql/mysql.sock
                  set-variable = max_allowed_packet=8M
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    things still didn't work. The link I posted above showed that there was a third file to be edited, namely /etc/httpd/conf.d/php.conf
                    It is THIS file that contains the directive LimitRequestBody and it is set to a default of 524288 (512kb) I changed it to 8388608 (8Mb)
                    I can't find it anywhere in /etc/httpd/conf.d/php.conf. How can I add that?

                    Comment


                    • #11
                      I tried everything I still unable to upload any video file. What am I doing wrong?

                      Comment


                      • #12
                        What is in your /etc/httpd/conf.d/php.conf? What version of Apache are you using?

                        You are looking for something like this:

                        <Files *.php>
                        SetOutputFilter PHP
                        SetInputFilter PHP
                        LimitRequestBody 20524288
                        </Files>

                        You could also try putting it in /etc/httpd/conf/httpd.conf and restarting apache.

                        Comment


                        • #13
                          This is whats in my file. I am running Apache/2.0.52 (Red Hat)
                          Code:
                           
                          #
                          # PHP is an HTML-embedded scripting language which attempts to make it
                          # easy for developers to write dynamically generated webpages.
                          #
                          LoadModule php4_module modules/libphp4.so
                          #
                          # Cause the PHP interpreter to handle files with a .php extension.
                          #
                          AddType application/x-httpd-php .php
                          # AddType application/x-httpd-php-source .phps
                          #
                          # Add index.php to the list of files that will be served as directory
                          # indexes.
                          #
                          DirectoryIndex index.php
                          
                          Now where would I add it?
                          Last edited by boataholic; Fri 21st Oct '05, 7:47am.

                          Comment


                          • #14
                            same issue not video but files 10mb or bigger don't upload I also could not find a php.conf
                            Originally posted by Annie^.^
                            I can't find it anywhere in /etc/httpd/conf.d/php.conf. How can I add that?

                            Comment


                            • #15
                              I am having this issue as well

                              I'm a noob.

                              I need to be able to allow people upload massive attachments, like videos. I have set the max for things like .avi to 99999999 in the attachment manager, moved the attachments to the file system and updated php.ini with upload_max_filesize = 500M.

                              I am running on a shared hosting plan on 1and1.com, so I am not able to change many of the things discussed in this thread.

                              What else can I try? This is a fundamental service we have to provide on the forum.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X