Announcement

Collapse
No announcement yet.

Error explanation please

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error explanation please

    Warning: main(./includes/config.php): failed to open stream: Permission denied in /home/blindsid/public_html/forums/includes/init.php on line 424

    Fatal error: main(): Failed opening required './includes/config.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/blindsid/public_html/forums/includes/init.php on line 424


    what is that?

  • #2
    Init.php cannot access config.php, this is not a good thing. HAve you recently recompiled php or made any changes to the vBulletin files?

    Comment


    • #3
      there's lots of problems.



      thanks.

      Comment


      • #4
        Try reuploading the original vBulletin files, ensure that your config.php file is in place and correctly configured.

        If you are still getting a problem you should try contacting your host and see if they have recompiled php

        Comment


        • #5
          I actually did re-upload everything and then got that problem.

          There was a hardware failure and some data loss, so I'm thinking that caused problems that were not easily detectable.

          A restore was done by the host and all is working well now, at least there.

          ...now to my next site. *sigh*

          Comment


          • #6
            Can't win 'm all. Sometimes hosting providers just can't do much after hardware failures, hopefully their backup was from before the failure and not months old. And hopefully it was from the same vBulletin version too.

            Comment


            • #7
              This may sound silly, but haev you tried to chmod 777 config.php, chown <your php/apache/root user> config.php yet?
              Best Regards,
              Andy Huang

              Comment


              • #8
                Floris - thankfully they have several days worth of recent updates, so I only lost about a day or two's worth of forum data. Also, the restore was the proper version, which is good, because as made obvious by the existence if this thread, my uploading of the same version files didn't work. ah, well...

                Alfarin - I didn't try that, but I did make sure the /includes folder was 777. Initially, it wasn't. I didn't specifically chmod the file itself, though. I have another site that's giving me the same errors, maybe I'll try it there.

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X