Announcement

Collapse
No announcement yet.

MySQL error changing or adding a user group profile

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Rod Neep
    replied
    No hacks have been installed. I haven't changed any of the code. In fact, I re-uploaded all of the original php etc. 3.0.3 "upload" files (as ASCII) again this evening to be sure they were all OK. (The ones on the remote server were all unchanged in file size and date anyway). - the whole board was only started a couple of days ago.


    So... OK... I'll create a support ticket... but before I do.... do you really mean all login info (username and pwds) for Admin CP, phpMyAdmin and FTP??? (Not sure about phpMyAdmin, as I access the server using Webmin as its in another place 30 miles from here, and to be honest, I don't even know what phpMyAdmin is).

    Thanks
    Rod

    ps. I still can't help feeling that this is something to do with the same problem that the Archives don't work.... and the bit in your manual that says:
    "The Search-Friendly Archive works only under the Apache web server with PHP compiled as a module."
    .... it is (I am told).... but perhaps it is an "older" version of PHP than is needed? The box is just over a year old.

    Leave a comment:


  • Steve Machol
    replied
    Have you installed any hacks (including portals) or added any code to the headinclude, header or phpinclude templates? If not, fill out a support ticket at:

    http://www.vbulletin.com/members/mem...ontactform.php

    Be sure to include the login info to your Admin CP, phpMyAdmin and FTP. If you have installed hacks or added code, then remove the hacks first then check and see if you still have this problem. If so, leave the default vB files in place and fill out the support request. Please also include a complete description of the problem.

    Leave a comment:


  • Rod Neep
    replied
    Added info...

    If I create a new user group .... off of Registered users (I called it fhs1) with all the same settings.....

    Then that worked nicely... I then went into that user group, checked the display avatars radio button.... no problem! It worked! Therefore the script is functioning OK.

    Rod

    Leave a comment:


  • Rod Neep
    replied
    Hmmm... uploaded it again. Still the same error.

    The User title for the registered group is empty

    Thanks
    Rod

    Leave a comment:


  • Steve Machol
    replied
    Reupload the original usergroup.php file from the vB 3.0.3 zip file. Make sure you upload in ASCII and overwrite the one on the server.

    If you still have this problem, then look at the User Title for the Registered group and report back what is there.

    Leave a comment:


  • Rod Neep
    started a topic MySQL error changing or adding a user group profile

    MySQL error changing or adding a user group profile

    Hmmm... a now you see me, now you don't problem

    A new installation

    Today I tried to add a new user group (based on standard registered user)
    (a special group to access some private forums).

    Many times I simply got an SQL error.
    mysql error: You have an error in your SQL syntax. Check the manual
    that corresponds to your MySQL server version for the right syntax to
    use near '[title, avatarmaxheight, avatarmaxsize, profilepicmaxwidth,
    pro
    mysql error number: 1064

    (Note: the error appears to be with avatars)

    Gave up. Came home from work, and tried it again.... pop!
    Worked first time! NO ERROR

    Now.... trying something else.... (from home) I keep getting a similar error when trying to change settings in the standard Registered Users group profile.... all I wanted to do is enable avatars. One radio button to select. Then save.

    ===================================
    Database error in vBulletin 3.0.3:
    Invalid SQL: UPDATE usergroup SET
    ### UPDATE QUERY GENERATED BY fetch_query_sql() ###
    title = 'Registered Users',
    description = '',
    usertitle = '',
    opentag = '',
    closetag = '',
    passwordexpires = '0',
    passwordhistory = '0',
    attachlimit = '0',
    avatarmaxwidth = '80',
    avatarmaxheight = '80',
    avatarmaxsize = '20000',
    canprofilepusergroup[title = 'Registered Users',
    profilepicmaxwidth = '100',
    profilepicmaxheight = '100',
    profilepicmaxsize = '65535',
    pmquota = '50',
    pmsendmax = '5',
    forumpermissions = '127487',
    pmpermissions = '3',
    calendarpermissions = '19',
    wolpermissions = '1',
    adminpermissions = '0',
    genericpermissions = '2627271',
    genericoptions = '30'
    WHERE usergroupid=2
    mysql error: You have an error in your SQL syntax. Check the manual
    that corresponds to your MySQL server version for the right syntax to
    use near '[title = 'Registered Users',
    profilepicmaxwidth = '100',
    prof
    mysql error number: 1064
    Date: Thursday 30th of September 2004 11:16:14 PM
    Script: http://www.british-genealogy.com/for.../usergroup.php
    Referer: http://www.british-genealogy.com/for...sergroup.php?s
    =&do=edit&usergroupid=2
    ==============================

    Why should I have had problems earlier when trying to add a new user group... but then succeeded?

    and now.... a similar problem? (Still not succeeding on this one though)

    Any help would be appreciated!

    and finally.... telling you the whole story, as it might just be related:
    If I click on "Archive" from my system....
    Error 404

    www.british-genealogy.com
    Fri Oct 1 00:56:16 2004
    Apache/2.0.44 (Unix)
    But everything else appears to be running super fine!
    http://www.british-genealogy.com/forums/

    Thanks
    Rod
Loading...
Working...
X