Announcement

Collapse
No announcement yet.

Members avatars will not upload

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Members avatars will not upload

    Members are having trouble uploading Avatars, it is nothing to do with size, I have tried myself and everthing is normal no error message and no avatar? not even a red X

    Not sure if it's connected by just tried to upload a Smilie and that did not show just an X, tried to upload it again and the .gif already exists so it made it to the file.

    Anyone help please? Thanks as always!

  • #2
    if you are hosting on an apache folder make sure the avatar folder is chmod to 777

    if you are NT make sure that the IUSR account can write to that folder


    same goes with the smilie folder

    Comment


    • #3
      I can still upload Avatars that people can choose and they are all set to 777 but still don't show and no error message.

      Comment


      • #4
        i know in my application there are 2 avatar folders. for the users i have setup a folder named customavatars. now i can't remember if this is a default or not. but that folder needs to be 777 as well

        Comment


        • #5
          What happens when you try the Upload diagnostics?

          Admin CP -> Import & Maintenance -> Upload

          In the Admin CP, open the Server Settings and Optimization Options section and turn on the Public phpinfo() Display Enabled setting. Then provide the URL to your forums. This may help us troubleshoot this problem.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            This is the message again when I try to upload

            file_uploads:Onopen_basedir:Nonesafe_mode:Offupload_tmp_dir:Noneupload_max_filesize:2M

            The attached file's temporary location (C:\WINNT\TEMP\php3573.tmp) could not be found. The test cannot continue.

            Have turned on the public php, my forum is www.shoppingtelly.com/forum

            Many thanks

            Comment


            • #7
              To get uploads to work in your Windows server, you or your host needs to edit your php.in file to add an upload_tmp_dir setting. It must point to a valid directory that is world-readable and writable. You may need to restart the web server after making this change.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Many thanks where is the php.in file situated had a look in the forums folder but can't see it.

                Do I put the readable file into the forums folder and name it upload_tmp_dir

                Thank you very much for your help.

                Comment


                • #9
                  You need to have root access to the server to do this. It will affect the whole server, not just your forums. The location of the php.ini file for your server is in the phpinfo page.

                  In the Admin CP, open the Server Settings and Optimization Options section and turn on the Public phpinfo() Display Enabled setting. You can then go to their forums and add &do=phpinfo to any page and it will display the phpinfo() page.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment


                  • #10
                    Brilliant - thank u all sorted and working!

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X