Announcement

Collapse
No announcement yet.

Authorize.net error message

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Authorize.net error message

    Hi,

    I bought vb3 yesterday to replace pp2BB because I need to offer paid subscriptions, which pp2BB doesn't provide. I need a ready to go solution since I can't hack.

    After installing and configure it to work with Authorize.net, I login as a registered user, go to UserCP, chose a subscription->order and then after I click on "order using Authorize.net" I get the following error on the next page:
    ____________________________________________
    The following errors have occurred.

    (97) This transaction cannot be accepted.
    ----------------------------------------------------
    If I keep hitting the back button and click on order again, eventually I get the order form which works perfectly with Authorize, but I don't expect my visitors to know that.

    Is this a known problem or am I doing something wrong ?

    In addition I would like to know if it is possible to configure Vb so that users have to pay to register, rather than having to register and then buy a subscription.

    tks.

  • #2
    I think the problem not accepting is due to the DDos attack against authorize.net at the moment. http://www.theregister.com/2004/09/2...e_ddos_attack/

    Regarding the payment before registration I dont see this happening as we need some sort of reference for who the payment is for and the best thing we have is a userid. Though I'll add another option which shows an error page saying they have to pay for a subscription before they can view anything.

    You'll just have to prune those in the registered usergroups who haven't paid once a week or month.
    Scott MacVicar

    My Blog | Twitter

    Comment


    • #3
      Authorize.net problem

      I got and email (see quote below) from Authorize.net today stating that the DDoS problems they were having have been solved. However I keep having the same problem when trying to charge a customer for a subscription.

      I would call Authorize and ask about a solution, but they will ask me things such as how am I passing variables, etc, and since I don't have a clue about programming I woudn't know the answers.

      I really need this subscription working properly. Please help !!!

      tks.
      Carlos

      Comment


      • #4
        check your settings for authorize.net, which are required and wich are not. FOr example if you tell authorize.net that phone numbers are required and vb is not transmitting that info you might get a message like the one above. just an idea

        Comment


        • #5
          It may be authnet and the script

          I've been getting this same error message for the past several days. It's really hurting my subscriptions. I'll try to track the problem, but I hope someone does.

          I did get an email about a month ago stating that they were going to turn "password required mode" on for EVERYONE to help cut back on credit card fraud this holiday season. This could be the problem. The authorize.php script may be incompatible now....
          AKA "ChurchMedia"
          CMN.NU

          Comment


          • #6
            I tracked down the error message:

            Applicable only to SIM API.Fingerprints are only valid for a short period of time. This code indicates that the transaction fingerprint has expired.
            I've always had a problem withe Fingerprints in this script. It uses "TIMENOW" as part of the Fingerprint. The problem with that is that by the time they go from one page to another "TIMENOW" has changed. I had by-passed the Fingerprint to get the script to work at all. Now it's dead in the water. Any help from the vBulletin team is appreciated.
            AKA "ChurchMedia"
            CMN.NU

            Comment


            • #7
              Problem Solved

              I found the problem. My server clock was off by more than 15 minutes. Reset your server clock and the problem should go away.
              AKA "ChurchMedia"
              CMN.NU

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X