Announcement

Collapse
No announcement yet.

*another* problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • *another* problem

    Install is now completed and when I went to log in to the admin cp I got a 404 error saying login/php did not exist so I reinstalled login.php and now I get this on the admin cp
    There seems to have been a slight problem with the database.
    Please try again by pressing the refresh button in your browser.

    An E-Mail has been dispatched to our Technical Staff, who you can also contact if the problem persists.

    We apologise for any inconvenience.

  • #2
    Please right click the page and view the source, it will disclose the full error message.

    We need that message before we can determine what might be wrong.

    Comment


    • #3
      I emailed my host and asked them and they said to delete everything and make sure got it uploaded correctly (aparantley there was a file in the wrong place) so we did and now we're stuck on step 2 of installation again. Here's my error
      Step 2) Connect to the database

      Attempting to attach to database

      Connect failed: unexpected error from the database.

      Error number: 1044

      Error description: Access denied for user: '[email protected]' to database 'werbeyond_com_-_forum'

      Please ensure that the database and server is correctly configured and try again.

      I went back in to my site control panel and made sure that the database name and password were the same as what was on the config.php but it's still not working.

      Comment


      • #4
        This error means either:

        1. One or more of the following is wrong in your config.php file:

        $servername (except in rare case, this should almost always be left as 'localhost')
        $dbusername
        $dbpassword
        $dbname

        If you are unsure of what the appropriate values are then you will need to ask your web host.

        2. Or that this db user is not assigned to that database or does not have permission to access MySQL to create or access a database. You may need to first manually create the database and assign the db user to it. Since each web host is different, if you do not know how to do this then contact your web host for help.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html><head> <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" /> <title>vBulletin 3.0 Install Script Step 2) Connect to the database</title> <link rel="stylesheet" href="../cpstyles/vBulletin_3_Default/controlpanel.css" /> <style type="text/css"> #all { margin: 10px; } #all p, #all td, #all li, #all div { font-size: 11px; font-family: verdana, arial, helvetica, sans-serif; } </style></head><body style="margin:0px"><table cellpadding="4" cellspacing="0" border="0" width="100%" class="navbody" style="borderutset 2px"><tr> <td width="160"><img src="../cpstyles/vBulletin_3_Default/cp_logo.gif" alt="" title="vBulletin 3 &copy;2000 - 2004 Jelsoft Enterprises Ltd." /></td> <td style="padding-left:100px"> <b>vBulletin 3.0 Install Script</b><br /> (Please be patient as some parts may take some time)<br /> <br /> <b style="font-size:10pt;">Step 2) Connect to the database</b> (Step 2 of 13)</td></tr></table><div id="all"><p style="font-size:10pt;"><b><u>Step 2) Connect to the database</u></b></p><p>Attempting to attach to database</p><br /><b>Warning</b>: mysql_errno(): supplied argument is not a valid MySQL-Link resource in <b>/var/www/html/upload/includes/db_mysql.php</b> on line <b>140</b><br /><p><font size="+1" color="red"><b>The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.</b></font></p> </div> <form action="install.php" method="get" name="nextStep"> <input type="hidden" name="step" value="3" /> <table cellpadding="4" cellspacing="0" border="0" width="100%" class="navbody" style="padding:4px; borderutset 2px;"> <tr align="center"> <td>vBulletin &copy;2000 - 2004 Jelsoft Enterprises Ltd.</td> <td></td> </tr> </table> </form> </div><!-- START CONTROL PANEL FOOTER --><p align="center"><a href="http://www.vbulletin.com/" target="_blank" class="copyright">vBulletin v3.0.3, Copyright &copy;2000 - 2004, Jelsoft Enterprises Ltd.</a></p></div></body></html> ok here is the page source info

          Comment


          • #6
            Just like the error says:

            database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.

            Contact your hosting provider and ask them to confirm these settings. And ask them what host you should connect to and if you have permission to connect to that host, database, as that user.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X