No announcement yet.

Restoring Database Already On Server

  • Filter
  • Time
  • Show
Clear All
new posts

  • Restoring Database Already On Server

    I've been reading threads/topics on restoring databases all morning, and I can't seem to find the answer to my question. So, here goes....

    I saved a backup of my database via the boards admin control panel, and the database was saved as a file on my server. I then downloaded a copy of the backup file to my PC, and tried to upload it via mymsql. The file size is 19.8mb, so of course I recieved a timeout error.

    I've read many topics about telnet/ssh, but according to my host:

    "at this time, we do not provide telnet access or SSH to your files. You may, however, use telnet to connect to port 110 (incoming mail) and port 25 (outgoing mail). You will not be able to access files using telnet or SSH on our shared hosting plans."

    Outside of asking my host to restore the database for me, is there any other route I can take? If I have to, I'll ask the hosting company to do it for, but I'd like to learn how to do it myself so that I don't have to contact them each and every time I run into this issue.

    Since the file is already on the server in my backup folder, is there a way for me to restore it without the use of telnet/ssh?

    Thanks in advance for your assistance!

    Best regards,


  • #2
    You could try.


    • #3
      Only backing and restoring via the shell is reliable. However you can try this:

      Restore with phpMyAdmin:
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography

      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.