Announcement

Collapse
No announcement yet.

Attachment problem...?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Attachment problem...?

    Here's the error I get when I try to upload a simple JPG image in the control panel. Everything seems to be turned on for PHP uploads + SQL packet size (which should be the problem in the first place).

    Warning: Unable to create '\home\site\www\msgboard\attachments/a66c7c73484fec680c0ed7529970a1c6': No such file or directory in /home/site/www/msgboard/includes/functions_file.php on line 274

    Warning: Unable to move '/tmp/phpzU0USJ' to '\home\site\www\msgboard\attachments/a66c7c73484fec680c0ed7529970a1c6' in /home/site/www/msgboard/includes/functions_file.php on line 274

    Warning: stat failed for \home\site\www\msgboard\attachments/a66c7c73484fec680c0ed7529970a1c6 (errno=2 - No such file or directory) in /home/site/www/msgboard/includes/functions_file.php on line 286

    Any ideas?

  • #2
    What do you have for the attachment directory in your attachment settings in the Admin CP?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I have it set to a directory rather than storing them in the database...

      Comment


      • #4
        Yes I know. What directory do you have this set for?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol
          Yes I know. What directory do you have this set for?
          I have it set for home\site\www\msgboard\attachments\ and I chmod'd 0777 with root login, and this is the msg I get.

          We attempted to write a test file to home\site\www\msgboard\attachments\, but we were unsuccessful. Please verify that the web server has write/delete permissions for this path.

          Any other alternatives?

          Comment


          • #6
            Try setting it to:

            \home\site\www\msgboard\attachments\
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              I get the same error

              Comment


              • #8
                Well, since you're in Linux, you better change the direction of the slashes methinks....

                Comment


                • #9
                  Also make sure the folder is chmoded.

                  Comment


                  • #10
                    SWEET!! That worked!

                    Only now I tried to post an attachment to the board as an Administrator (who is invisible to users). But when it says that it's been uploaded and I hit the post button, I dont see the attachment that was supposed to be posted. Is that because Im an administrator?

                    When I go to the attachment stats in the adminCP I can clearly see that it's been uploaded, but I dont see it under the post which I posted it to...

                    Any ideas?

                    Thanks!

                    Comment


                    • #11
                      Are attachments being moderated?
                      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                      Change CKEditor Colors to Match Style (for 4.1.4 and above)

                      Steve Machol Photography


                      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                      Comment


                      • #12
                        Originally posted by Steve Machol
                        Are attachments being moderated?
                        I dont think so, but where can I check this?

                        Comment


                        • #13
                          It's a per forum setting. Check the setting for Moderate Attachments in the Forum Manager.
                          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                          Change CKEditor Colors to Match Style (for 4.1.4 and above)

                          Steve Machol Photography


                          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                          Comment


                          • #14
                            Originally posted by Steve Machol
                            It's a per forum setting. Check the setting for Moderate Attachments in the Forum Manager.
                            It's not being moderated. It's weird. Even some of my users are posting and cant see the attachment under the post. The attachment gets uploaded just fine, but not in the post...?

                            Comment


                            • #15
                              Nevermind Steve, it's all good. I had to make sure that GD was enabled plus I had to make sure all the settings were right in the admincp global settings...

                              It's working great now, thanks so much for your help!

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X