Announcement

Collapse
No announcement yet.

Problem with sessionhash!!!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with sessionhash!!!

    I noticed a cookie problem at my forum www.spiritual-connections.com .

    In my config.php stands:

    // Prefix that all vBulletin cookies will have
    // For example
    $cookieprefix = 'bb';

    All my cookie info reads with bb in front of it whats right apart from sessionhash what is giving me a problem because it can not read the cookie to see if somebody logged in because its not bbsessionhash whats odd with all the other cookie bits having the bb in front of them.

    This brings some problems to my forum because a few of my members must login again after they posted or hacks like this one: http://www.spiritual-connections.com/forums/bbmessenger don't work

    Here is a screenshot of the problem: http://www.spiritual-connections.com/Image1.jpg

    Can anybody help me with this problem?

  • #2
    Since this is the default cookie prefix I don't understand what the issue is. Can you please explain why this prefix is a problem? I couldn't quite understand.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Like I said this brings some problems to my forum because a few of my members must login again after they posted or hacks like this one: http://www.spiritual-connections.com/forums/bbmessenger don't work.

      All my cookie info reads with bb in front of it whats right apart from sessionhash. So I believ that is the problem but I don't know why sessionhash has no bb before it and I need to know how to change it.

      Comment


      • #4
        So this is a conflict with one of your hacks then? Why don't you try changing the cookie prefix to something else?
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Didn't know that I can do it without making any more troubles. So I can change it... for example to:

          $cookieprefix = 'vb';

          will that change the sessionhash to vbsessionhash, too?

          My problem is that sessionhash has no prefix at my forum.

          Comment


          • #6
            sessionhash, does not get the cookie prefix, the cookie prefix, is for the cookie itself, not a sesson value.

            Comment


            • #7
              Try it and see. However since you have installed hacks you may want to post over at vbulletin.org if you have further problems.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                ah so sessionhash has never a cookie prefix?

                If you look at this screenshot http://www.spiritual-connections.com/Image1.jpg then you see what I mean. At my forum is sessionhash without bb.

                Comment


                • #9
                  Nope, i dont think it would. At least from what I understand.

                  Comment


                  • #10
                    My forum has a prefix on the sessionhash. I compared it when you submitted the support ticket.

                    Comment


                    • #11
                      Mmh so there is a prefix on the sessionhash. Weird don't understand why I have this problem.

                      Comment


                      • #12
                        After checking (had to pull out firefox) i noticed that it did get prefixed O.o But i do not remember seeing it in the past.

                        Do you have any specific cookie settings? like domain and folder?

                        Comment


                        • #13
                          No, all is default.

                          Comment


                          • #14
                            Did you try uploading the original PHP files yet? That is a necessary first step in troubleshooting a problem like this, especially when you have hacks installed. If you can eliminate the files as the problem then that narrows down the possibilities quite a lot. The same goes for indentifying the files as the problem.

                            Comment


                            • #15
                              I am running a test forum with all the original files and have the same problem.

                              I uploaded the mycookie script, now. Look here: http://www.spiritual-connections.com.../mycookies.php it is weird all files have the bb prefix before just not sessionhash.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X