Announcement

Collapse
No announcement yet.

Localhost installation not working...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Localhost installation not working...

    I installed Apache on my local computer. Version 2.0.50. Using URL http://localhost brings up an Apache screen. This is working fine.

    Installed PHP. Version 5.0.0. Ran a test.php file and it is working fine.

    Installed MySQL 4.0.20 and went into the command prompt and created databases, changed the root password, granted rights to user to use a database. The databases I created would be the same used on the production server. The users granted rights were to this new database.

    I changed the config.php to reflect the server as 'localhost' - user name I used the same above that was created for the database and used the newly created database name.

    I created a folder under HTDOCS from the apache server location. Under that folder will be all the documents for this site. I moved the upgade files to the subdirectory forums.

    I ran the install and it only comes up with the blank screen. The url used was http://localhost/4by5/forums/install/install.php.

    I tried the vb_test.php found in another link but it states it can not find the function mysql_connect. When I open MySql admin I only see the 'test' database that is loaded when Mysql is installed. I do not see the database I created. I found another thread that cautions about the Google toolbar. I uninstalled this. I also found a thread that stated I need to correct the file php.ini and remove the semi-colon in front of the following statement: ;extension=php_mysql.dll

    That same thread suggested moving the following file to windows system32 subdirectory: libmysql.dll.

    After all of this it is still coming up with a blank screen. OPPS forgot to mention I am running WINDOWS XP Home version.

  • #2
    I am having the same problem. I didn't have this problem when I was using Windows 2000.

    Can someone help?
    War is only fun when you are winning.

    Comment


    • #3
      You need to enable the mysql libarys for php5

      For windows, uncomment the mysqllib.dll line

      Comment


      • #4
        yay! I got it to work now.

        I uncommented the line "extension=php_mysql.dll" in php.ini and I no longer get a blank install page after I reboot my computer.

        Kehfera, you may want to reboot the computer after you made the php.ini changes if u haven't already. Also, make sure your extension_dir is correct (should point to the "ext" folder)...
        War is only fun when you are winning.

        Comment


        • #5
          You will just need to restart apache2

          Comment


          • #6
            I am having the same problem and have my pages hosted so can't do much about the PHP 5 thing. (PHP 4 something is installed and works with everything else I run.) I purchased the software after reading that PHP4 is the minimum requirement, and my hosting company doesn't like to make changes to shared accounts anyway. I really didn't want the extra hassel and cost of finding another hosting company just to run this, so is there any way to get this to work otherwise, because I'm really feeling a little miffed right now.

            I have edited everything in config.php. Here's the error I get at my admin address when the blank install page comes up.

            Code:
            Database error in vBulletin :
            
            Invalid SQL: 
            				SELECT title, data
            				FROM forumdatastore
            				WHERE title IN ('options', 'cron', 'forumcache', 'usergroupcache', 'stylecache', 'userstats', 'birthdaycache', 'maxloggedin', 'iconcache', 'eventcache', 'mailqueue')
            			
            mysql error: Table 'vbforums.forumdatastore' doesn't exist
            
            mysql error number: 1146

            Comment


            • #7
              It looks like you've set your table prefix to 'forum'. Are all the vB tables using that prefix?
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Well, I tried it again using vbforums for both the database name and the prefix. I created a new database for this with phpmyadmin called vbforums (just to test), and made sure the user account/password and everything else was right in config.php. Still nothing, in fact now I just get a blank page, with no emailed errors, at least not yet.

                I’m wondering if permissions have to be set temporarily on certain files to allow execution for the install, though I tries it with install.php and a few others and it didn’t seem to work.

                Also, when I go back into phpmyadmin and look into the database vbforums there have been no tables or anything else at all created.

                How would I tell if all the tables are using that prefix or not? Doesn't that get set using the variable from config.php?

                Comment


                • #9
                  What are the names of your vB tables? Do they have a prefix?
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X