Announcement

Collapse
No announcement yet.

How Do I: Enable the WYSIWYG Editor?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How Do I: Enable the WYSIWYG Editor?

    Hey there,

    How do I enable the WYSIWYG editor? For instance, you click a smiley, and it shows in the advanced text area.

    Also hyperlinks show up in editing mode, and the text and URL pop up in a single window? etc...


    ?

    rob

  • #2
    To do this, first you must enable it in the Admin CP:

    Admin CP --> vBulletin Options --> Message Posting Interface Options --> Enable Clickable Message Formatting Controls --> Enable Standard & WYSIWYG Controls

    Then you and your users must enable it in the User Control Panel:

    User CP --> Edit Options --> Message Editor Interface

    If you'd like all of your users to have this option enabled:

    Admin CP --> Import & Maintenance --> Execute SQL Query --> Automatic Query --> Show Enhanced (WYSIWYG) Editor Toolbar

    (Note: To set all of the users to have the WYSISYG Editor you must have your user ID in the proper section of the config.php file. For more information regarding that, see here (towards the bottom)).
    Bugdar: PHP bug tracking software that is beautiful, fast, and robust.

    Comment


    • #3
      Any Side effects?

      What are the side effects of enabling the enhanced WYSIWYG editor toolbar? Does this require more database queries, or possibly just more computational power on the user's end?

      If there are good reasons not to enable this cool enhanced view, it would be nice to know because this appears to be an action (Show Enhanced Auto Query) that can not be un-done.

      Is that the case?


      Thanks,

      rob

      Comment


      • #4
        The WYSIWYG editor shouldn't require any more queries, but it may require a second more to load for the user.

        If you use the automatic query, your users can return it off in their User CP. And there's also an automatic query to make everybody not use the WYSIWYG toolbar. So it's pretty undoable.
        Bugdar: PHP bug tracking software that is beautiful, fast, and robust.

        Comment


        • #5
          When I post something with WYSIWUG advanced editor on my site, I get a message that says you must have a least one character and it won't allow any of us to post. Anyone know how to correct this problem?

          Comment


          • #6
            Originally posted by Techlion126 View Post
            When I post something with WYSIWUG advanced editor on my site, I get a message that says you must have a least one character and it won't allow any of us to post. Anyone know how to correct this problem?
            Anyone know how to fix this.

            Comment


            • #7
              What are you posting exactly? You need to post something other than a smilie or BB code.

              If you need futher assistance please start your own thred in the correct forum for your version with all the relevant details.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                Originally posted by daemon View Post
                To do this, first you must enable it in the Admin CP:

                Admin CP --> vBulletin Options --> Message Posting Interface Options --> Enable Clickable Message Formatting Controls --> Enable Standard & WYSIWYG Controls

                Then you and your users must enable it in the User Control Panel:

                User CP --> Edit Options --> Message Editor Interface

                If you'd like all of your users to have this option enabled:

                Admin CP --> Import & Maintenance --> Execute SQL Query --> Automatic Query --> Show Enhanced (WYSIWYG) Editor Toolbar

                (Note: To set all of the users to have the WYSISYG Editor you must have your user ID in the proper section of the config.php file. For more information regarding that, see here (towards the bottom)).
                thx sooo much... this was just what i was lookin for to solve my problemo...2nd one today ! vb.com rocks!

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X