Announcement

Collapse
No announcement yet.

Add Links on the Nav bar, to different parts of the site other than forums

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Add Links on the Nav bar, to different parts of the site other than forums

    I am trying to add a few buttons next to quick links and search and link to a different area. I am trying to link it to /photopost and to /reviewpost.

    I am in the "navbar" template and am trying to use this source...

    <td class="vbmenu_control"><a href="search.php?$session[sessionurl]do=getdaily">$vbphrase[todays_posts]</a></td>

    If I change it to :


    <td class="vbmenu_control"><a href="www.texasatvs.com/photopost/[sessionurl]do=getdaily">$vbphrase[photos]</a></td>

    Am I using the wrong code? How do I do this?

    It wants to link it to www.texasatvs.com/forums/www.texasatvs.com/photopost/???

    how do I go about this,

    Thanks for your help!!!!
    www.texasatvs.com

  • #2
    just change it to


    <td class="vbmenu_control"><a href="www.texasatvs.com/photopost>Photos</a>

    $vbphrase[photos] is not a valid phrase, $vbphrase's are done thru the vbulletin coding, you need not try to add your own variation to it just do the link i showed you above and do it to the other link you needed also
    Rebel Designs Studios

    Comment


    • #3
      Thanks for your help, I added the code , but it didn't add any text on the nav bar when you go to the forums...

      Is everything done correctly? Here is the code:


      <td class="vbmenu_control"><a href="www.texasatvs.com/photopost>Photos</a></td>

      <td class="vbmenu_control"><a ref="www.texasatvs.com/reviewpost>Reviews</a></td>
      <else />
      <td class="vbmenu_control"><a href="search.php?$session[sessionurl]do=getdaily">$vbphrase[todays_posts]</a></td>
      </if>
      <td id="navbar_search" class="vbmenu_control"><a href="search.php?$session[sessionurl]">$vbphrase[search]</a> <script type="text/javascript"> vbmenu_register("navbar_search"); </script></td>
      www.texasatvs.com

      Comment


      • #4
        bump
        www.texasatvs.com

        Comment


        • #5
          <td class="vbmenu_control"><a href="www.texasatvs.com/photopost$session[sessionurl]">Photos</a></td>

          and then

          <td class="vbmenu_control"><a href="www.texasatvs.com/reviewpost$session[sessionurl]">Reviews</a></td>


          Sorry about that My Ice, i forgot to add the </td> one the end and the session :P

          It was a long day yesterday
          Rebel Designs Studios

          Comment


          • #6
            To me this looks like, as if it inside that condition:

            <if condition="$show['popups']">

            Maybe you'll find your Link to the Photopost when you open that Search-Popup. *g*

            Add it before that code, so that it looks like this:

            Code:
            <td class="vbmenu_control"><a href="/photopost>Photos</a></td>
            <td class="vbmenu_control"><a ref="/reviewpost>Reviews</a></td>
            <if condition="$show['popups']"> 
            <if condition="$show['searchbuttons']">
            	<if condition="$show['member']">
            	<td class="vbmenu_control"><a href="search.php?$session[sessionurl]do=getnew" accesskey="2">$vbphrase[new_posts_nav]</a></td>
            	<else />
            	<td class="vbmenu_control"><a href="search.php?$session[sessionurl]do=getdaily" accesskey="2">$vbphrase[todays_posts]</a></td>
            	</if>
            That's the way, I added links to it, and it works just fine.

            Comment


            • #7
              Originally posted by rebelsrock06
              <td class="vbmenu_control"><a href="www.texasatvs.com/photopost$session[sessionurl]">Photos</a></td>

              and then

              <td class="vbmenu_control"><a href="www.texasatvs.com/reviewpost$session[sessionurl]">Reviews</a></td>


              Sorry about that My Ice, i forgot to add the </td> one the end and the session :P

              It was a long day yesterday
              Thanks for your help!! But I added the exact links you posted and when I click the link in the nav bar, it puts the link after the forums/ directory.

              Instead of going to www.texasatvs.com/photopost/
              It goes directly to www.texasatvs.com/forums/www.texasatvs.com/photopost/

              Take a look at my index. www.texasatvs.com/forums/ and you can see what im talking about. Thanks so much for your help!!!!
              www.texasatvs.com

              Comment


              • #8
                bump, anyone know this????

                Thanks for all your help!!!
                www.texasatvs.com

                Comment


                • #9
                  you need to put http:// before the www
                  Rebel Designs Studios

                  Comment


                  • #10
                    Hm. Photopost is one the same server, isn't it?

                    So you don't need to put http://www.texasatvs.com in front of it.

                    Did you try, what I posted, MyIce?

                    Comment

                    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                    Working...
                    X