Announcement

Collapse
No announcement yet.

Problem with vb3, Mozilla Firefox & DHTML scripts.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem with vb3, Mozilla Firefox & DHTML scripts.

    I have (had) the following DHTML script installed on my board (pasted in a few templates) in order to prevent visitors from highlighting (and copying) text:


    <script language="JavaScript1.2">
    //Disable select-text script (IE4+, NS6+)- By Andy Scott
    //Exclusive permission granted to Dynamic Drive to feature script
    //Visit http://www.dynamicdrive.com for this script
    function disableselect(e){
    return false
    }
    function reEnable(){
    return true
    }
    //if IE4+
    document.onselectstart=new Function ("return false")
    //if NS6
    if (window.sidebar){
    document.onmousedown=disableselect
    document.onclick=reEnable
    }
    </script>


    And it works fine with Internet Explorer.

    But, with Firefox, it creates the problem of not being able to post; because the little blinking cursor slash (you know what I'm talking about, right?) never shows up.


    Anybody know how to fix this (Firefox) problem without removing the text-highlight script?

  • #2
    Its still more than possible for anyone to get the text just would take them longer.

    Have you checked at dynamic drive to see if they have an updated version?

    Comment


    • #3
      ^

      No, but I will.

      And I know it's still possible to copy the text with the script installed, but the fact that it'll take longer; specifically the fact that less people would know how to copy it with the script installed (than without it); is precisely the point.

      Comment


      • #4
        Originally posted by Marcel Lee
        No, but I will.

        And I know it's still possible to copy the text with the script installed, but the fact that it'll take longer; specifically the fact that less people would know how to copy it with the script installed (than without it); is precisely the point.
        did you ever find a resolution for this? I'm having the exact same problem right now.

        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X