Announcement

Collapse
No announcement yet.

upgrade dies at 41

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    Ahh, that post is over a year old and obviously vB was beta at that time. I've removed that reference.

    Leave a comment:


  • petermw
    replied
    ok

    I got that from the first line of the first sticky message in the "Vbulletin 3 Installation and Upgrades" forum:

    "People seem to be forgetting that this release is a BETA version of the program and not warranted to be bug free."...

    Anyway... wasnt getting those errors until after I jumped step 41 so there was no way to forsee them. I have a backup DB and will try and restore it.
    Thanks for the help, and I will post the results
    P

    Leave a comment:


  • Steve Machol
    replied
    Uh, where did you get the idea that vB 3.0.3 is a 'beta' release? It most certainly is not. However to get from 2.2.9 to 3.0.3, you will need to run through a noumber of upgrade scripts.

    Also you should have mentioned alll the other 'errors' you were getting. In general principle it's not a good idea to just ignore errors and p0low through.

    At this point you should start all over. I would restore the 2.2.9 backup of the database you made prior to attempting this upgrade. It would be best to resote it to a fresh db. Then run the database conflicts script prior to attempting the upgrade:

    http://www.vbulletin.com/forum/showt...threadid=73163

    Then if there are no conflicts, try the upgrade again. If you get any errors, stop and report them here.

    Leave a comment:


  • petermw
    replied
    Well, I tried that and then when upgrading through all the beta's I get all kinds of errors related to importing vbulletin_settings.xml. So a pretty error laden install all the way around, and the index page displays the following:
    Parse error: parse error, unexpected $ in /home/filmwurl/public_html/forums/index.php on line 414

    What happens next? Should I start over?
    Peter

    PS is 3.0 a beta release? If so, I think you all should write "beta" in every possible spot (top right graphic of this page, forum name etc, vBulletin 3_0 folder name etc etc). I didn't realize that this might be a possibility until after the install...
    Last edited by petermw; Sat 24 Jul '04, 12:02pm.

    Leave a comment:


  • Steve Machol
    replied
    Try going to the next step:

    http://www.filmwurld.com/forums/inst...e1.php?step=42

    Leave a comment:


  • petermw
    started a topic upgrade dies at 41

    upgrade dies at 41

    So close, yet so far away.... what should I do? Thanks in advance,
    Peter


    There seems to have been a slight problem with the FilmWurld database.
    Please try again by pressing the refresh button in your browser.
    An E-Mail has been dispatched to our Technical Staff, who you can also contact if the problem persists.

    We apologise for any inconvenience.

    in my email:

    Database error in vBulletin 2.2.9:

    Invalid SQL:
    INSERT INTO setting
    (varname, grouptitle, value, defaultvalue, optioncode, displayorder, advanced, volatile)
    VALUES
    (
    'avatarenabled',
    'userpix',
    '0',
    '1',
    'yesno',
    10,
    0,
    1
    ),
    (
    'numavatarswide',
    'userpix',
    '5',
    '5',
    '',
    20,
    0,
    1
    ),
    (
    'numavatarsperpage',
    'userpix',
    '0',
    '10',
    '',
    30,
    0,
    1
    ),
    (
    'profilepicenabled',
    'userpix',
    '1',
    '1',
    'yesno',
    40,
    0,
    1
    )
    mysql error: Duplicate entry 'numavatarsperpage' for key 1

    mysql error number: 1062

    Date: Saturday 24th of July 2004 12:21:04 PM
    Script: http://www.filmwurld.com/forums/install/upgrade1.php?step=41
    Referer: http://www.filmwurld.com/forums/install/upgrade1.php?step=40
    IP Address: 24.215.148.239
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X