Announcement

Collapse
No announcement yet.

Fix for blank install.php or upgrade.php page.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fix for blank install.php or upgrade.php page.

    For those of you looking for an answer to this problem, I can offer some help. After working on this for HOURS today, I have determined that my RPM installation of Apache and PHP is the root of my issues.

    The problem is likely related to PHP's compilation. After reading about this the most commonality I discovered is related to XML. It must be switched on properly when PHP is compiled. A default install of Redhat 9 Server does not compile PHP with this switch. See the following link:

    http://www.vbulletin.com/forum/showthread.php?t=98665

    Anyway, I ended up following the instructions on this site and totally abandoning the default install of Apache & PHP. Here's the details:

    Download PHP. Put in /usr/local/src

    cd /usr/local/src/php-xxx
    ./configure --prefix=/usr/local/php --with-config-file-path=/usr/local/php --with-mysql --with-apache=../apache_xxx --enable-track-vars --enable-debugger --enable-magic-quotes --with-xml=shared
    make
    make install
    Note: The vBulletin install manual does NOT include "--with-xml=shared" at the end of the ./configure command above. I added that portion after finding it on this forum. Someone should really tell them to modify their manual. It sucks for that reason.

    Anyway, download the latest Apache 1.x. I haven't done Apache 2.x... there is no help for it in the manual either. For that reason, I stick to 1.x... Put it in /usr/local/src.

    cd /usr/local/src/apache_xxx
    ./configure --prefix=/usr/local/etc/httpd --activate-module=src/modules/php4/libphp4.a
    make
    make install
    Go to /usr/local/etc/httpd/bin and run ./apachectl start
    You will no longer use "service httpd start"

    The script should work...
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X