Announcement

Collapse
No announcement yet.

Thread views stopped working

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Thread views stopped working

    My thread views stopped adding up, instead my views only add up after they get a reply, and that is only one per reply. Like I made a few threads in my Annoucements section that were important and closed them, this was 3 days ago, and they only have one view a piece when I know they have been viewed a LOT.

    I did not edit any type of code, nor installed any type of hack.

    Anyone?

  • #2
    Try toggling this setting:

    Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Update Thread Views Immediately

    You might also try running a repair:

    Admin CP -> Import & Maintenance -> Repair / Optimize Tables

    Comment


    • #3
      Tried both, checked out ok/no errors.

      Not sure what else this could be, anyone else?

      Comment


      • #4
        Have you installed any hacks (including portals) or added any code to the headinclude, header or phpinclude templates? If not, fill out a support ticket at:

        http://www.vbulletin.com/members/mem...ontactform.php

        Be sure to include the login info to your Admin CP, phpMyAdmin and FTP. If you have installed hacks or added code, then remove the hacks first then check and see if you still have this problem. If so, leave the default vB files in place and fill out the support request.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          If that setting is disabled:

          Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Update Thread Views Immediately

          Then try manually running the scheduled task that updates thread views:

          Admin CP -> Scheduled Tasks -> Scheduled Task Manager

          Run the Thread Views task and see if that updates the thread views. Then edit that task and enable the Log Entries option so you can view the log later to make sure the task is running.

          Also make sure your footer template contains this code or the scheduled tasks will not run:

          Code:
          	<!-- Do not remove $cronimage or your scheduled tasks will cease to function -->
          	$cronimage
          	<!-- Do not remove $cronimage or your scheduled tasks will cease to function -->
          If you continue to have a problem then we will need to take a look. Submit a support ticket with a login for your server and forums.

          Comment


          • #6
            Originally posted by Jake Bunce
            Admin CP -> Scheduled Tasks -> Scheduled Task Manager

            Run the Thread Views task and see if that updates the thread views. Then edit that task and enable the Log Entries option so you can view the log later to make sure the task is running.
            ^ That worked, thanks!

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X