Announcement

Collapse
No announcement yet.

large attatchments timing out

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • large attatchments timing out

    I am getting a 2006 sql error and sometimes the upload page timing out, trying to upload large attatchments.

    I had no my.cnf file so I copied over the my-medium.cnf file to use.
    What do I need to modiy to allow large (up to 20MB) attatchments? I already changed the size limit in the control panel with no effect.

  • #2
    Youll need to modify, php's max upload mysqls max packet size as well.

    Comment


    • #3
      I added this to my mysql server startup...

      ./mysqld_safe --max_allowed_packet=10M

      That did the job for me. Not sure what you can do if you don't control the mysql server. In your case you'd make it 20M
      UT Gaming Community - http://www.unrealghetto.com

      Comment


      • #4
        php is already at 200MB.

        I changed packets to 30MB and restarted.

        The upload attatchments page still times out to cannot find server after 1 minute of uploading.

        Comment


        • #5
          Couple things to check...

          Resource Limits in the php.ini file.

          Timeout in the httpd.conf file for Apache (if thats what you are using). I think default is 300 for it. Is your upload so big that you cannot upload your file within the Timeout limit of your web server? If so you might need to up that limit to something big enough for a user to be able to send the largest allowed file at a relatively slow speed. So how long would it take to send a 20mb file at X kps?
          UT Gaming Community - http://www.unrealghetto.com

          Comment


          • #6
            Also you might want to take a look at this for other settings that affect file uploads:

            http://www.vbulletin.com/forum/showp...0&postcount=12
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              Increasing memory_limit did it - thanks!

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X