Announcement

Collapse
No announcement yet.

Error on Upgrade Attempt

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    Download the .php versions without a shebang and you should be good to go if you have .php being parsed by php4 now.

    Comment


    • #62
      Ok - I'll give it another try - without the Shebang on it.

      As an aside - since I'm here, writing this - one of the things I was considering was trying to restore the db via Telnet with a back up I have of the db from January. I would lose more than a 1000 posts - but at least I would not lose everything (which is what I am worried about happening now).

      The syntax on your boards is as follows:

      Step Three - Restore to new server
      • Telnet/SSH into machine2
      • create a database on the mysql if necessary (ask your server admin for help with this as it varies from machine to machine)
      • at the prompt type
        mysql -uUSERNAME -p newdbname < /path/to/dump.sql
      • this takes a couple of minutes depending on your database size, but you can track the progress either by FTP (checking the /mysql/data/newdbname and see the files appearing) or by phpMyAdmin (you should see the files appearing there)
      • when it is completed, it will bring you back to the prompt
      </FONT></FONT></FONT></FONT></FONT></FONT>
      I've tried this a couple of times - verbatim - with my passcodes, etc - and the syntax keeps failing. Could you please confirm the correct syntax to use on the third step - I don't see a command - unless the '<' is the command...

      Please advise - and thanks.

      //sse

      Comment


      • #63
        Nope - but it seems like we're getting closer.

        This:

        Yeilded this:

        Fatal error: Call to unsupported or undefined function require_once() in /usr/www/users/ssengle/ericson/infoexchange/install/upgrade.php on line 28
        And line 28 in upgrade.php is:

        require_once('./includes/init.php');
        That line has been cited over and over... Any ideas?



        //sse

        Comment


        • #64
          Which version were you running and do you have a good backup of the database?
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #65
            I'm upgrading now from 2.3.5 to 3x (whatever the newest version is). I have a good backup of the db (a MySQL backup) and a 90% backup from the AdminCP (sans the attachements - something was goofy there - was making it fail).

            Comment


            • #66
              So you didn't make a complete backup prior to attempting the upgrade?
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #67
                Originally posted by SeanE
                Nope - but it seems like we're getting closer.

                This:

                Yeilded this:

                And line 28 in upgrade.php is:

                That line has been cited over and over... Any ideas?



                //sse
                Anytime you see an error regarding require_once, that indicates that PHP3 is being used. This is the same thing I pointed out to you before. You have to use PHP 4.0.6 or later.

                Comment


                • #68
                  Yeah, I know - I just did the phpinfo thing again - and it came up 3.1.8 or whatever. I've got a job ticket in with Pair Networks, asking them where the hell the setting is for it. You don't have any idea where they typically have such settings, do you?

                  I don't get it - I had it set to 4x earlier today - it was coming through as 4x - and have not changed the settings.

                  I'll deal with this tomorrow - or Monday - 14 hours is enough.
                  //sse

                  Comment


                  • #69
                    And on the backup - no - I could not. I sold this site in January - they got hacked last week and called me - asking me to try and fix it. They never backed it up once. My last good backup was when I sold it - January. The others are after the matter.


                    //sse

                    Comment


                    • #70
                      You can close this ticket - I finally figured out what the problem was - as you pointed out - it was the assignment of the MIME type on one of the parent folders. I changed it out - and while it nailed one of my minor cutsie php apps on the front of the site (easy to replace) I saw the most welcome site I've seen in four days below.

                      Thanks for all your help you guys - I'll be staying tuned to the news here from now on - I only have a few non-gray hairs left!

                      //sse
                      Attached Files
                      Last edited by SeanE; Sun 11 Jul '04, 10:02am.

                      Comment

                      Related Topics

                      Collapse

                      Working...
                      X