Announcement

Collapse
No announcement yet.

Lost my forums due to upgrade 3.0.2!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lost my forums due to upgrade 3.0.2!

    Sooo I have read everything on every thread about the upgrade...I too had the same issues as others with the data base errors....I made the corretions need like it was suggested my the staff and members...I also had a today freash back up of the sql and the site...

    Sooooo after 3 hours of screwing around and nothing was working like every else said it should....I dropped my sql again, uploaded the backup and uploaded my back of the site....

    Now Im missing the forums!!!!!!!! I can't even use the search to see if the forums are there...there is nothing!


    Please check it out and let me know...I mean if the sql was backed up today before the upgrade and I dropped it and re-uploaded the backup, everything should be normal!?!?!?

    I need help please!


    www.bodybuildingcentral.net/forums
    Last edited by Vman; Sat 3 Jul '04, 11:50am.

  • #2
    Are you sure thet backup you restored was a complete one? Did you restore it to a fresh database rather than the existing one? Have you looked at the database directly with phpMyAdmin to see if there is any data in the post table?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Please explain 'how' you upgraded, from which version and which errors.

      Comment


      • #4
        Ok, Ill try and explain alittle more...

        Version 3.0.1 to 3.0.2

        I shut the portal and the board down for upgrading
        I downloaded the 3.0.2 and upzipped it....
        I then went ahead and moved all the files in the upload folder to my ftp
        I then continued to the upgrade.php. Everything worked upto the point on step 4. I was getting duplicate error messaged in pollid, cpsession, and on other on...I went thru the thread of member who had the same problems which were identified...still nothing worked...In one thread a member said to drop your data base and re-upload your back, which should take care of the duplication errors...I did that....
        I then compaired the database to make sure it was the one I just backed up hours prior (And yes it was a complete backup)
        I then ran upgrade.php again and again I got the same errors, I then went in manually and dropped the sections it was giveing errors on...I then ran upgrade.php again and from what I noticed, each time I removed the errors manully, the upgrade placed those tables right back into the areas where they were needed, but then gave the error messages...

        By this point I figure I would be able to by pass step 4 and move to step 5 which was also stated in a thread...I did that and everything worked great and was able to finish the upgrade...I was then in my AdminCP....

        I went to the forum and Nope, not there! I was also getting portal errors...

        So my this point I said I had enough and would do a complete restore of the backup I did hours prior...that all went well, the portal is up and running, but when you goto the main board from portal, the forums are missing!

        Whenever I did drop the sql database I used MyAdminPhP and it worked fine...

        So that is my store and I still am at a loss!!!

        Comment


        • #5
          You mentioned errors during the upgrade. What are the exact errors? What did you do after you got those errors?

          Also which 'portal' are you taling about? Have you installed any hacks or portals?
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Hay Steve...I got it to work again...Im back on 3.0.1 When re-uploading the backup files I had a corrupt .xml style for vB 3.0.1

            As for the portal, its vPortal

            Now I want to try and upgrade again...But I don't want to go thru all this again after 10 plus hrs!!!!

            But I will do this just to post the errors to see what Im talking about...Soooooo here I go!

            The 3 hacks I have are the "Welcome Hack", "Shout Box" and "Hack Tracking Log" those are it!

            Comment


            • #7
              Ill wait until I get a responce first before I attempt the upgrade...to see what you will suggest...

              Comment


              • #8
                What suggestion are you waiting for? It would also help to know which version you are upgrading from.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  Im Upgrading from 3.0.1~

                  Now here is the first error I just got on step #4

                  Database error in vBulletin 3.0.1:

                  Invalid SQL: ALTER TABLE administrator ADD notes MEDIUMTEXT NOT NULL
                  mysql error: Duplicate column name 'notes'

                  mysql error number: 1060

                  Date: Saturday 03rd of July 2004 10:19:17 PM
                  Script: http://www.bodybuildingcentral.net/f...e13.php?step=4
                  Referer: http://www.bodybuildingcentral.net/f...e13.php?step=3


                  Do you want me to manully remove this and then press the refresh?

                  Comment


                  • #10
                    This means that either one of your hacks has created this column which interfers with 3.0.2, or you have already attempted to run the upgrade on this database once before.

                    The answer on what to do next depends on whether or not this is from a hack. If it's not, then you should be able to go to the next step. If it is, then you of course will have a big problem with that hack.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      OK, now I have deleted the hacks I have and now I get this!


                      Database error in vBulletin 3.0.1:

                      Invalid SQL: ALTER TABLE thread ADD INDEX pollid (pollid)
                      mysql error: Duplicate key name 'pollid'

                      mysql error number: 1061

                      Date: Saturday 03rd of July 2004 10:49:39 PM
                      Script: http://www.bodybuildingcentral.net/f...e13.php?step=4
                      Referer: http://www.bodybuildingcentral.net/f...e13.php?step=3

                      Comment


                      • #12
                        I fixed it and now its working great!
                        The problem was the pollid and I had 3 copies of it in the column...I deleted them and it allowed me to continue thru the upgrade...

                        Comment


                        • #13
                          Can you explain BBCVman,how can you delete ? Because same problem me...

                          Thanks

                          Comment


                          • #14
                            Originally posted by Bulent Tekcan
                            Can you explain BBCVman,how can you delete ? Because same problem me...

                            Thanks
                            Well, ill try and explain....Go into your PHPMYADMIN and look at your sql database. then scroll down the left side until you see "Poll", click that, your right screen should bring up everthing for that.

                            Then in the main screen on the right, scroll to the bottom and you will see what has been INDEX

                            For me I saw Pollid_2, Pollid_3 and Pollid. Next to them you will see the option to "Edit" or "Drop" You will want to "Drop" them....

                            Now at the very top of the Big column you will see another "Pollid" Leave that!!!! No Not Delete/Drop that one...

                            That was it, I then hit "refresh" and continued thru the upgrade with no more problems!...

                            Hope that helped

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X