Announcement

Collapse
No announcement yet.

PayPal does not changes automatically usergroups

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PayPal does not changes automatically usergroups

    Hello. Please, excuse my bad English.
    I have used paid subscriptions with paypal without problems for several days, but today suddenly the paid members don´t change automatically to paid usergroup. I receive the mail notification of paypal and I change them manually to the paid usergroup. I have not made changes in paypal nor paid subscriptions.

    Is there anything wrong with paypal or it´s a problem of mine or of vbulletin?

    Best regards.

  • #2
    Its possible your host may have changed something does changing your avatar to a remote url in the usercp still work? It uses similar fetching code.
    Scott MacVicar

    My Blog | Twitter

    Comment


    • #3
      Hello, I am on a dedicated server, no changes have been made in the host. I have avatars in /customavatars and I have not problems changing my avatar from my PC or a remote URL.

      Comment


      • #4
        Today, without any changes in my board nor my host nor paypal, the paid subscriptions are working OK.


        Regards

        Comment


        • #5
          I think the change is happening at PayPal.... I'm experiencing the same problem... I get the emails, but the member ID and subscription ID is no longer provided, which explains why vB doesn't do anything in terms of updates.....
          vB Drupal Community Plumbing | vB Survey | vBusy | vB Spell | vBouncer

          Comment


          • #6
            Originally posted by tamarian
            I think the change is happening at PayPal.... I'm experiencing the same problem... I get the emails, but the member ID and subscription ID is no longer provided, which explains why vB doesn't do anything in terms of updates.....
            Please disregard.....

            It turns out that for some reason the last two subscribers decided to not use the subscription form, and payed directly to my email without using the vB form.
            vB Drupal Community Plumbing | vB Survey | vBusy | vB Spell | vBouncer

            Comment


            • #7
              Im having a similar problem - no one can sign up to the paid subscriptions

              when running the test I get these messages

              Server communication to processor

              Paypal cURL Fail
              Streams Pass

              NOCHEX cURL Fail
              Streams Fail

              the paypal / nochex accounts are correct in the settings area - any ideas ?

              there are no hacks on the board this is a fresh install
              Digital-Forums: www.digital-forums.com | CK3 Games: www.ck3.co.uk

              Comment


              • #8
                If your server doesnt have cURL your not going to be able to use paypal or other subscrition methods

                Comment


                • #9
                  I had the same problem- with 3.0.1 I was able to get the money, but the users did not change on their own.. upon using the support ticket system, I was told to wait until 3.0.2 came out, and it would be ok. After installing the new release, I get the same commication result as stated above- cURL failed.. so question 1) how can I tell if my server has this? (again, beginner here, please forgive me) and 2) if they don't have it, this means subscriptions are out the window now?

                  Thank you for your assistance!

                  Comment


                  • #10
                    Enable your publicphpinfo in the admincp and ill take a look and can tell you,

                    No, if you dont have it, you should be able to ask your host to recompile php with curl support.

                    Comment


                    • #11
                      Thank you Zachery.. I enabled it.. and also contacted my host in regards to cURL support..
                      http://silentwarriors.net/community

                      (and wow, if you werent talking to me about that, I shall feel dumb later..LMAO)

                      Edited to add, this was my servers response:
                      "You may tell the Vbulletin techs that cURL is installed on our servers.
                      And many of our shared hosting and dedicated customers are using
                      Vbulletin.

                      Also note that for security reasons, PHP is not compiled with cURL, It
                      is suggested to use command line cURL."
                      Last edited by cutetxblonde; Sat 3 Jul '04, 1:27pm.

                      Comment


                      • #12
                        I dont see curl support in your phpinfo, not to mention your host is running php as cgi instead of as a modual(not that this is insanely bad, but it causes more problems than good)

                        Comment


                        • #13
                          Thanks for the help Zachery.. looks like I am SOL on subscriptions at this point..

                          Comment


                          • #14
                            Having problems too - am using 3.0.1

                            host supports curl - have added IPN thingy at paypal, added correct paypal email addy - add subscriptions correctly (primary usergroup no change but selected seondary usergroup)

                            paypal happily take my money and sending confirmation emails but not returning to my site correctly.

                            It returns to a page on my site but not the subscriptions page - the page it goes to is forums/index].php but for some reason it has a ] in too so the page isn't displayed

                            I've rechecked all my typing eg my forum url, the link I added into paypal and can't see anywhere I've mistyped the url or included a ] and don't understand why it picked that page instead of the one I told it at paypal .... /forums/subscriptions/paypal

                            can this be done with 3.0.1 or should I upgrade to 3.0.3 first?

                            Comment


                            • #15
                              I am having the exact same problem with 3.0.1. cURL is enabled but sometimes the usergroups dont get changed for some reason. When that happens, all subscriptions in that time frame act the same way, then all of a sudden it works fine and continues to work fine.

                              So if I get an email from a subscriber saying its not working, I immediately go and check all other subscriptions around that timeframe and all of them act the same way. And when things work, they all work ok for a day or two. Its weird, and started happening around 21st/22nd of this month. No server or any other changes were made whatsoever.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X