Announcement

Collapse
No announcement yet.

Mod link on footer for Moderators?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Jake Bunce
    replied
    I know the file edit works. You did something wrong.

    The template mod you applied works as an alternative, so you can ignore the file mod since that is working for you.

    Leave a comment:


  • Zachery
    replied
    When you say you made the user a moderator, did you actually assign them to a forum, or add them to the moderator group?

    Leave a comment:


  • ntburchf
    replied
    Originally posted by Jake Bunce
    Are your regular mods added as mods in your:

    Admin CP -> Forums & Moderators -> Forum Manager -> Add Moderator (in the menus on the right)
    ?
    That is what makes some one a regular moderator. They are not a moderator if they are just in the Moderator usergroup.
    Does not work for me vb 3.07
    Just switched from phpbb to this.

    Uncommented the global.php
    made test user a mod in forums

    Link does not show up-
    Now, if I create a test group and make test group supermod, put test user in it, then the link will show up.

    I may not want all my users that I want to be mods - supermods-
    I just want them to have the link to the modcp when they have the rights to mod a forum--

    What am I missing here?

    update--
    had to
    replace in the footer
    Code:
     <if condition="$show['modcplink']"><a href="$modcpdir/index.php?$session[sessionurl]">$vbphrase[mod]</a> -</if>
    with this
    Code:
     <if condition="can_moderate()"><a href="$modcpdir/index.php?$session[sessionurl]">$vbphrase[mod]</a> -</if>
    Last edited by ntburchf; Fri 8 Jul '05, 11:54pm.

    Leave a comment:


  • Jake Bunce
    replied
    Are your regular mods added as mods in your:

    Admin CP -> Forums & Moderators -> Forum Manager -> Add Moderator (in the menus on the right)

    ?

    That is what makes some one a regular moderator. They are not a moderator if they are just in the Moderator usergroup.

    Leave a comment:


  • Hektor
    replied
    Supermods can see it but mods can't. I must be missing something here.

    Leave a comment:


  • Jake Bunce
    replied
    global.php in your main forum directory.

    Leave a comment:


  • FrankR678
    replied
    which file would this code be in?

    Leave a comment:


  • tarzanna
    replied
    Perfect! Thank you....

    Leave a comment:


  • Jake Bunce
    replied
    global.php in your main forum directory.

    Leave a comment:


  • tarzanna
    replied
    This is probably such a dumb question....but what file is it that I make the above changes too? I've looked through several...but I must just be missing it....

    Leave a comment:


  • Martyjp
    replied
    Cheers worked perfectly, you wouldnt believe how many complaints I got about that

    Leave a comment:


  • Jake Bunce
    replied
    Oh, you also need to comment the line below it. So you end up with this:

    Code:
    // This generates an extra query for non-admins/supermods on many pages so we have chosen to only display it to supermods & admins
     $show['modcplink'] = iif(can_moderate(), true, false);
    // $show['modcplink'] = iif ($permissions['adminpermissions'] & CANCONTROLPANEL OR $permissions['adminpermissions'] & ISMODERATOR, true, false);

    Leave a comment:


  • Martyjp
    replied
    may be me being stupid but I found uncommenting that line hasnt made any difference as mods still cant see the link *puzzled*

    Leave a comment:


  • Jake Bunce
    replied
    Yeah, it shouldn't be noticable.

    Leave a comment:


  • Oblivion Knight
    replied
    Originally posted by Jake Bunce
    Yes, it is safe to uncomment.

    As the comments say, that line was commented because it added a query, that's all.
    Thanks for answering Jake..
    I assume the extra query shouldn't effect server load too much judging from your reply?

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X