Announcement

Collapse
No announcement yet.

Got Killed on Step 2/13

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Got Killed on Step 2/13

    Here is the message:
    Step 2) Connect to the database

    Attempting to attach to database


    Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in /home/lextreme/public_html/2jz/includes/db_mysql.php on line 140
    The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.

  • #2
    Originally posted by Lextreme
    Here is the message:
    Step 2) Connect to the database

    Attempting to attach to database


    Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in /home/lextreme/public_html/2jz/includes/db_mysql.php on line 140
    The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.
    Open config.php check the username, password,host and db name are all correct. then save and reupload.
    Give that a try and see what happens.

    Comment


    • #3
      I'll try and get it to supress the PHP warning message in a future release since its a bit confusing having 2 messages.
      Scott MacVicar

      My Blog | Twitter

      Comment


      • #4
        After correctly the user name, password and email address. Here are the errors:

        Step 2) Connect to the database

        Attempting to attach to database

        Connect failed: unexpected error from the database.

        Error number: 1044

        Error description: Access denied for user: 'lextreme@localhost' to database '2jz'

        Please ensure that the database and server is correctly configured and try again.

        I know its database.... that is what i am stuck on.

        Comment


        • #5
          This error means either:

          1. One or more of the following is wrong in your config.php file:

          $dbusername
          $dbpassword
          $dbname

          If you are unsure of what the appropriate values are then you will need to ask your web host.

          2. Or that this db user is not assigned to that database or does not have permission to access MySQL to create or access a database. You may need to first manually create the database and assign the db user to it. Since each web host is different, if you do not know how to do this then contact your web host for help.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            ok i suppose its my turn now---
            i am cpying and pasting my post from a diff thread since i didnt know to log in making me able to post it here where its more relivant
            (THANKS STEVEN)




            i have been actually reading search queries on this site related to my currrent problem for over 3.5 hrs

            Good evening by the way everyone......


            my problem is the same that i have seen on a dozen(literaly) pages that come up when searching for "MYSQL"

            most ppl are stuck on step two i belive....where the DB is not rexognised and the username seems to not have permissions

            well
            this is alittle different

            i do understand what i am doing completely when i install a new DB to use for V-Bulletin

            and i do understand that my username & password will be PREFIXED with my domain name essentially

            so
            everything is in order
            the DB
            $dbname = 'clubexl_forum'
            the user name
            $dbusername = 'clubexl_REMOVED BY ME';
            the password
            $dbusername = 'clubexl_REMOVED BY ME';

            but i still get the same message seen all over the site

            -----------------------
            Step 2) Connect to the database

            Attempting to attach to database


            Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in /home/virtual/clubexl/public_html/forum/upload/includes/db_mysql.php on line 140

            The database has failed to connect because you do not have permission to connect to the server. Please confirm the values entered in the 'includes/config.php' file.

            --------------------------------

            ok im at a total loss at this point
            so lets start with the questions and see if we can make this happen

            by the way
            this is a NEW install - not an upgrade or a patch


            thanks in advance everyone

            Comment


            • #7
              The answer to this problem is still the same as I posts in post #5:

              http://www.vbulletin.com/forum/showp...54&postcount=5
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                correct i made sure all these sections of info were 100% accurate
                and i still get the same message
                i checked with my host and all info is still 100% accurate

                still occurs

                ..anything else?

                Comment


                • #9
                  Well do you have a control panel to manage your MySQL databases?

                  Cpanel / Ensim and Plesk all have one.
                  Scott MacVicar

                  My Blog | Twitter

                  Comment


                  • #10
                    yes sir i do.
                    cpanelX
                    but i started reading though the the code in a my sql file
                    there was a code error
                    i did fix it
                    and it works now

                    thanks for your time- was a simple < out of place

                    Comment


                    • #11
                      Ok.

                      http://www.vbulletin.com/docs/html/cpanel_database

                      Is also a good reference.
                      Scott MacVicar

                      My Blog | Twitter

                      Comment


                      • #12
                        Make sure that the database you create, in which to hold the vbulletin files, is in lower case.That's if it's on a linux server, anyway.
                        An obvious point, which I thought would and should have been mentioned.
                        I hope that helps some folks.

                        Thanks!

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X