Announcement

Collapse
No announcement yet.

Database error in vBulletin emails

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database error in vBulletin emails

    Hi all

    Lately my host has been having issues with databases. The result of this is thousands of emails per hour stating;

    Database error in vBulletin :

    Link-ID == false, connect failed
    mysql error:
    ........
    This is good to be told once, but preferably not each and every time. Is there something I can do to stop my own forum spamming me?

  • #2
    Originally posted by Dave Hawley
    Is there something I can do to stop my own forum spamming me?
    Remove your email address from the includes/config.php file.

    Comment


    • #3
      You can also set this in the Admin CP:

      Admin CP -> vBulletin Options -> Error Handling & Logging-> Disable Database Error Email Sending-> Yes

      If you would like to prevent vBulletin from sending email to the $technicalemail address you specified in config.php, set this value to 'Yes'.
      1. Error reports about database connection errors will still be sent.
      2. It is not recommended that you set this value to 'Yes' unless you are logging database errors to a file. (see above)
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        I was about to post that too, but then I saw the note under the setting:

        Error reports about database connection errors will still be sent.
        The errors are connection errors, so I assume that won't work.

        Comment


        • #5
          True, I didn't notice that. Makes you wonder what emails it does block then.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Thanks guys. I was really hoping to be alerted only once, rather than 100 times per minute. As you can imagine, I need to know about problems such as these, but not so often

            Comment


            • #7
              You can always log the errors to a file instead of to your email. This can be done in the same section of the Admin CP that Steve posted.

              Comment


              • #8
                Cheers, thanks Jake and Steve, I'll check this out.

                Comment


                • #9
                  I have choose Yes at Admin CP -> vBulletin Options -> Error Handling & Logging-> Disable Database Error Email Sending->

                  however, it continues to send emails. any idea to stop them? I am on 3.0.3

                  Comment


                  • #10
                    Are the errors "database connection" errors? If so then vBulletin will continue to send the emails regardless of that setting because it makes an exception for this type of error.

                    In this case you need to remove your email address from the includes/config.php file.

                    Comment


                    • #11
                      it's database connection error, i see.

                      just a suggestion, I agree the #1, such an error just need drop one email, don't need 100 email a minute. Hopefully it could be fixed soon. Thanks.

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X